# CVE-2014-1402: Incorrect Privilege Assignment in Jinja2

> Local attackers can escalate privileges by exploiting insecure temporary file creation in the default Jinja2 bytecode cache configuration.

- **Severity:** Medium 4.4 (`AV:L/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 May 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-1402, GHSA-8r7q-cvjq-x353, MGASA-2014-0028, PYSEC-2014-8, RHSA-2014:0747, RHSA-2014:0748

## What is CVE-2014-1402?

CVE-2014-1402 is a medium-severity vulnerability in n/a, published on 19 May 2014. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The default configuration for bccache.FileSystemBytecodeCache in Jinja2 before 2.7.2 does not properly create temporary files, which allows local users to gain privileges via a crafted .cache file with a name starting with __jinja2_ in /tmp.

Weakness: CWE-264

## Which versions are affected by CVE-2014-1402?

3 open source packages ship an affected version, including jinja2 and Jinja2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jinja2` | PyPI | All versions | 2.7.2 |
| `jinja2` | PyPI | All versions | 2.7.2 |
| `Jinja2` | PyPI | All versions | 2.7.2 |
| `python-jinja2` | Red Hat:enterprise_linux:6::client | All versions | 0:2.2.1-2.el6_5 |
| `python-jinja2-debuginfo` | Red Hat:enterprise_linux:6::client | All versions | 0:2.2.1-2.el6_5 |
| `python-jinja2` | Red Hat:enterprise_linux:6::computenode | All versions | 0:2.2.1-2.el6_5 |
| `python-jinja2-debuginfo` | Red Hat:enterprise_linux:6::computenode | All versions | 0:2.2.1-2.el6_5 |
| `python-jinja2` | Red Hat:enterprise_linux:6::server | All versions | 0:2.2.1-2.el6_5 |
| `python-jinja2-debuginfo` | Red Hat:enterprise_linux:6::server | All versions | 0:2.2.1-2.el6_5 |
| `python-jinja2` | Red Hat:enterprise_linux:6::workstation | All versions | 0:2.2.1-2.el6_5 |
| `python-jinja2-debuginfo` | Red Hat:enterprise_linux:6::workstation | All versions | 0:2.2.1-2.el6_5 |
| `python27-python-jinja2` | Red Hat:rhel_software_collections:1::el6 | All versions | 0:2.6-10.el6 |
| `python33-python-jinja2` | Red Hat:rhel_software_collections:1::el6 | All versions | 0:2.6-11.el6 |
| `python27-python-jinja2` | Red Hat:rhel_software_collections:1::el7 | All versions | 0:2.6-11.el7 |
| `python33-python-jinja2` | Red Hat:rhel_software_collections:1::el7 | All versions | 0:2.6-12.el7 |

Products: Pocoo Jinja2.

## How do I fix CVE-2014-1402?

Upgrade jinja2 to 2.7.2 or later.

## Is CVE-2014-1402 being exploited?

There is no known exploitation of CVE-2014-1402 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-0012](https://insights.sbomify.com/CVE-2014-0012/): Insecure Temporary File in Jinja2 (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-1402 and fix it if it is affected.

What it is: CVE-2014-1402 is a medium-severity vulnerability in n/a, published on 19 May 2014. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-1402 in the wild and no public exploit code.

Affected packages and fixed versions:
- jinja2 (PyPI): affected all versions; fixed in 2.7.2
- jinja2 (PyPI): affected all versions; fixed in 2.7.2
- Jinja2 (PyPI): affected all versions; fixed in 2.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-1402/ (Markdown: https://insights.sbomify.com/CVE-2014-1402/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-1402
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-1402
- OSV: https://osv.dev/vulnerability/CVE-2014-1402

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-1402/
Summaries are generated and may contain mistakes; the official description above is the record.
