{"answers":{"affected":"It affects 13 products.","exploited":"There is no known exploitation of CVE-2014-1491 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2014-1491 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 6 Feb 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-1491 and fix it if it is affected.\n\nWhat it is: CVE-2014-1491 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 6 Feb 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-1491 in the wild and no public exploit code.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-1491/ (Markdown: https://insights.sbomify.com/CVE-2014-1491/index.md)","id":"CVE-2014-1491","markdown":"https://insights.sbomify.com/CVE-2014-1491/index.md","name":"CVE-2014-1491","record":{"aliases":["DEBIAN-CVE-2014-1491","GHSA-v496-3mj8-fpc6","RHSA-2014:0979"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Mozilla NSS library","requires_auth":"none","summary":"Remote attackers can bypass cryptographic protections in ticket handling due to improper restriction of Diffie-Hellman public values in the NSS library.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mozilla","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"firefox","vendor":"mozilla"},{"product":"network_security_services","vendor":"mozilla"},{"product":"seamonkey","vendor":"mozilla"},{"product":"thunderbird","vendor":"mozilla"},{"product":"opensuse","vendor":"opensuse"},{"product":"enterprise_manager_ops_center","vendor":"oracle"},{"product":"vm_server","vendor":"oracle"},{"product":"linux_enterprise_desktop","vendor":"suse"},{"product":"linux_enterprise_server","vendor":"suse"},{"product":"linux_enterprise_software_development_kit","vendor":"suse"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:N/A:N","version":"2.0"},"cwes":[{"id":"CWE-326","name":"Inadequate Encryption Strength"}],"description":"Mozilla Network Security Services (NSS) before 3.15.4, as used in Mozilla Firefox before 27.0, Firefox ESR 24.x before 24.3, Thunderbird before 24.3, SeaMonkey before 2.24, and other products, does not properly restrict public values in Diffie-Hellman key exchanges, which makes it easier for remote attackers to bypass cryptographic protection mechanisms in ticket handling by leveraging use of a certain value.","ecosystems":["Red Hat:enterprise_linux:6::hypervisor"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Weak cryptography in n/a","id":"CVE-2014-1491","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux","fedoraproject:fedora","mozilla:firefox","mozilla:network_security_services","mozilla:seamonkey","mozilla:thunderbird","opensuse:opensuse","oracle:enterprise_manager_ops_center","suse:linux_enterprise_desktop","suse:linux_enterprise_server","suse:linux_enterprise_software_development_kit"],"type":"weak_cryptography","year":"2014"},"n_packages":1,"n_references":32,"next":{"headline":"Security feature bypass in n/a","id":"CVE-2014-1492"},"packages":[{"ecosystem":"Red Hat:enterprise_linux:6::hypervisor","fixed":["0:6.5-20140725.0.el6ev"],"introduced":["0"],"last_affected":[],"package":"rhev-hypervisor6","purl":"pkg:rpm/redhat/rhev-hypervisor6","source":"RHSA-2014:0979"}],"prev":{"headline":"Use after free in n/a","id":"CVE-2014-1490"},"products":["n/a"],"published":"2014-02-06","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can bypass cryptographic protections in ticket handling due to improper restriction of Diffie-Hellman public values in the NSS library.","url":"https://insights.sbomify.com/CVE-2014-1491/"}