# CVE-2014-1624: pyxdg Arbitrary File Overwrite via Race Condition

> Local attackers can overwrite arbitrary files via a race condition in the runtime directory handling of the python-xdg library.

- **Severity:** Low 3.3 (`AV:L/AC:M/Au:N/C:N/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jan 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-1624, GHSA-7372-q459-jxhr, PYSEC-2014-95, SUSE-SU-2019:2719-1, SUSE-SU-2019:2719-2, UBUNTU-CVE-2014-1624

## What is CVE-2014-1624?

CVE-2014-1624 is a low-severity vulnerability in n/a, published on 28 Jan 2014. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Race condition in the xdg.BaseDirectory.get_runtime_dir function in python-xdg 0.25 allows local users to overwrite arbitrary files by pre-creating /tmp/pyxdg-runtime-dir-fallback-victim to point to a victim-owned location, then replacing it with a symlink to an attacker-controlled location once the get_runtime_dir function is called.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2014-1624?

3 open source packages ship an affected version, including pyxdg. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyxdg` | PyPI | All versions | 0.26 |
| `pyxdg` | PyPI | All versions | 0.26 |
| `pyxdg` | PyPI | From 0.25 | 0.26 |
| `python-xdg` | SUSE:Linux Enterprise Desktop 12 SP4 | All versions | 0.25-9.3.1 |
| `python-xdg` | SUSE:Linux Enterprise Server 12 SP4 | All versions | 0.25-9.3.1 |
| `python-xdg` | SUSE:Linux Enterprise Server 12 SP5 | All versions | 0.25-9.3.1 |
| `python-xdg` | SUSE:Linux Enterprise Server for SAP Applications 12 SP4 | All versions | 0.25-9.3.1 |
| `python-xdg` | SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 0.25-9.3.1 |

Products: Python Pyxdg.

## How do I fix CVE-2014-1624?

Upgrade pyxdg to 0.26 or later.

## Is CVE-2014-1624 being exploited?

There is no known exploitation of CVE-2014-1624 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-12761](https://insights.sbomify.com/CVE-2019-12761/): Code Injection in PyXDG (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-1624 and fix it if it is affected.

What it is: CVE-2014-1624 is a low-severity vulnerability in n/a, published on 28 Jan 2014. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-1624 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyxdg (PyPI): affected all versions; fixed in 0.26
- pyxdg (PyPI): affected all versions; fixed in 0.26
- pyxdg (PyPI): affected from 0.25; fixed in 0.26

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-1624/ (Markdown: https://insights.sbomify.com/CVE-2014-1624/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-1624
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-1624
- OSV: https://osv.dev/vulnerability/CVE-2014-1624

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-1624/
Summaries are generated and may contain mistakes; the official description above is the record.
