{"answers":{"affected":"3 open source packages ship an affected version, including requests. It affects 2 products.","exploited":"There is no known exploitation of CVE-2014-1830 in the wild and no public exploit code.","fix":"Upgrade requests to 2.3.0 or later.","what":"CVE-2014-1830 is a medium-severity vulnerability in Opensuse Opensuse, published on 15 Oct 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-1830 and fix it if it is affected.\n\nWhat it is: CVE-2014-1830 is a medium-severity vulnerability in Opensuse Opensuse, published on 15 Oct 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-1830 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- requests (PyPI): affected all versions; fixed in 2.3.0\n- requests (PyPI): affected all versions; fixed in 2.3.0\n- requests (PyPI): affected all versions; fixed in 2.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-1830/ (Markdown: https://insights.sbomify.com/CVE-2014-1830/index.md)","id":"CVE-2014-1830","markdown":"https://insights.sbomify.com/CVE-2014-1830/index.md","name":"CVE-2014-1830","record":{"aliases":["DEBIAN-CVE-2014-1830","ECHO-746a-0a98-0b10","GHSA-652x-xj99-gmcc","PYSEC-2014-14","UBUNTU-CVE-2014-1830"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Python HTTP library","requires_auth":"none","summary":"A remote server can obtain sensitive proxy credentials from redirected requests in the python-requests library.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"opensuse","vendor":"opensuse"},{"product":"requests","vendor":"python"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:N/A:N","version":"2.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"Requests (aka python-requests) before 2.3.0 allows remote servers to obtain sensitive information by reading the Proxy-Authorization header in a redirected request.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Exposure of Sensitive Information to an Unauthorized Actor in Requests","id":"CVE-2014-1830","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"opensuse:opensuse","products":["opensuse:opensuse"],"type":"information_disclosure","year":"2014"},"n_packages":3,"n_references":6,"next":{"headline":"Insecure use of temporary files in passenger","id":"CVE-2014-1831"},"packages":[{"ecosystem":"PyPI","fixed":["2.3.0"],"introduced":["0"],"last_affected":[],"package":"requests","purl":null,"source":"GHSA-652x-xj99-gmcc"},{"ecosystem":"PyPI","fixed":["2.3.0"],"introduced":["0"],"last_affected":[],"package":"requests","purl":"pkg:pypi/requests","source":"GHSA-652x-xj99-gmcc"},{"ecosystem":"PyPI","fixed":["2.3.0"],"introduced":["0"],"last_affected":[],"package":"requests","purl":"pkg:pypi/requests","source":"PYSEC-2014-14"}],"prev":{"headline":"Exposure of Sensitive Information to an Unauthorized Actor in Requests","id":"CVE-2014-1829"},"products":["n/a"],"published":"2014-10-15","related":[{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2015-5957","kev_date_added":null,"published":"2015-09-28"},{"cvss_score":10,"headline":"Memory corruption in n/a","id":"CVE-2015-0491","kev_date_added":null,"published":"2015-04-16"},{"cvss_score":10,"headline":"Integer overflow in n/a","id":"CVE-2008-2388","kev_date_added":null,"published":"2008-06-06"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2010-1866","kev_date_added":null,"published":"2010-05-07"},{"cvss_score":9.3,"headline":"Other in n/a","id":"CVE-2015-0492","kev_date_added":null,"published":"2015-04-16"},{"cvss_score":8.8,"headline":"Memory corruption in n/a","id":"CVE-2014-0158","kev_date_added":null,"published":"2018-04-10"},{"cvss_score":8.8,"headline":"Null dereference in n/a","id":"CVE-2016-4343","kev_date_added":null,"published":"2016-05-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"A remote server can obtain sensitive proxy credentials from redirected requests in the python-requests library.","url":"https://insights.sbomify.com/CVE-2014-1830/"}