{"answers":{"affected":"2 open source packages ship an affected version, including passenger. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-1831 in the wild and no public exploit code.","fix":"Upgrade passenger to 4.0.38 or later.","what":"CVE-2014-1831 is a low-severity path traversal vulnerability in n/a, published on 19 Feb 2015. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-1831 and fix it if it is affected.\n\nWhat it is: CVE-2014-1831 is a low-severity path traversal vulnerability in n/a, published on 19 Feb 2015. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-1831 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- passenger (RubyGems): affected all versions; fixed in 4.0.38\n- passenger (RubyGems): affected all versions; fixed in 4.0.38\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-1831/ (Markdown: https://insights.sbomify.com/CVE-2014-1831/index.md)","id":"CVE-2014-1831","markdown":"https://insights.sbomify.com/CVE-2014-1831/index.md","name":"CVE-2014-1831","record":{"aliases":["DEBIAN-CVE-2014-1831","GHSA-c7j7-p5jq-26ff"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Passenger application server","requires_auth":"low_privilege","summary":"Local attackers can overwrite critical Passenger files via symlink attacks, potentially compromising application integrity.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"passenger","vendor":"phusion"}],"cvss":{"score":2.1,"severity":"low","source":"nvd","vector":"AV:L/AC:L/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[],"description":"Phusion Passenger before 4.0.37 allows local users to write to certain files and directories via a symlink attack on (1) control_process.pid or a (2) generation-* file.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Insecure use of temporary files in passenger","id":"CVE-2014-1831","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"path_traversal","year":"2014"},"n_packages":2,"n_references":6,"next":{"headline":"Insecure use of temporary files in Phusion passenger","id":"CVE-2014-1832"},"packages":[{"ecosystem":"RubyGems","fixed":["4.0.38"],"introduced":["0"],"last_affected":[],"package":"passenger","purl":null,"source":"GHSA-c7j7-p5jq-26ff"},{"ecosystem":"RubyGems","fixed":["4.0.38"],"introduced":["0"],"last_affected":[],"package":"passenger","purl":"pkg:gem/passenger","source":"GHSA-c7j7-p5jq-26ff"}],"prev":{"headline":"Exposure of Sensitive Information to an Unauthorized Actor in Requests","id":"CVE-2014-1830"},"products":["n/a"],"published":"2015-02-19","related":[{"cvss_score":9.8,"headline":"Phusion Passenger SpawningKit Contains Arbitrary Read/Write Vulnerability","id":"CVE-2018-12026","kev_date_added":null,"published":"2018-06-17"},{"cvss_score":8.8,"headline":"Insecure Permissions in Phusion Passenger","id":"CVE-2018-12027","kev_date_added":null,"published":"2018-06-17"},{"cvss_score":7.8,"headline":"Incorrect Access Control in Phusion Passenger","id":"CVE-2018-12028","kev_date_added":null,"published":"2018-06-17"},{"cvss_score":7.8,"headline":"Phusion Passenger uses a known /tmp filename","id":"CVE-2016-10345","kev_date_added":null,"published":"2017-04-18"},{"cvss_score":7.5,"headline":"RubyGems passenger gem allows remote attackers to delete files","id":"CVE-2012-6135","kev_date_added":null,"published":"2019-11-19"},{"cvss_score":5.3,"headline":"Phusion Passenger denial of service","id":"CVE-2025-26803","kev_date_added":null,"published":"2025-02-24"},{"cvss_score":5.3,"headline":"Phusion Passenger incorrect permission assignment","id":"CVE-2018-12615","kev_date_added":null,"published":"2018-06-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Local attackers can overwrite critical Passenger files via symlink attacks, potentially compromising application integrity.","url":"https://insights.sbomify.com/CVE-2014-1831/"}