# CVE-2014-1831: Insecure use of temporary files in passenger

> Local attackers can overwrite critical Passenger files via symlink attacks, potentially compromising application integrity.

- **Severity:** Low 2.1 (`AV:L/AC:L/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Feb 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-1831, GHSA-c7j7-p5jq-26ff

## What is CVE-2014-1831?

CVE-2014-1831 is a low-severity path traversal vulnerability in n/a, published on 19 Feb 2015. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Phusion Passenger before 4.0.37 allows local users to write to certain files and directories via a symlink attack on (1) control_process.pid or a (2) generation-* file.

## Which versions are affected by CVE-2014-1831?

2 open source packages ship an affected version, including passenger. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `passenger` | RubyGems | All versions | 4.0.38 |
| `passenger` | RubyGems | All versions | 4.0.38 |

Products: Phusion Passenger.

## How do I fix CVE-2014-1831?

Upgrade passenger to 4.0.38 or later.

## Is CVE-2014-1831 being exploited?

There is no known exploitation of CVE-2014-1831 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-12026](https://insights.sbomify.com/CVE-2018-12026/): Phusion Passenger SpawningKit Contains Arbitrary Read/Write Vulnerability (critical 9.8)
- [CVE-2018-12027](https://insights.sbomify.com/CVE-2018-12027/): Insecure Permissions in Phusion Passenger (high 8.8)
- [CVE-2018-12028](https://insights.sbomify.com/CVE-2018-12028/): Incorrect Access Control in Phusion Passenger (high 7.8)
- [CVE-2016-10345](https://insights.sbomify.com/CVE-2016-10345/): Phusion Passenger uses a known /tmp filename (high 7.8)
- [CVE-2012-6135](https://insights.sbomify.com/CVE-2012-6135/): RubyGems passenger gem allows remote attackers to delete files (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-1831 and fix it if it is affected.

What it is: CVE-2014-1831 is a low-severity path traversal vulnerability in n/a, published on 19 Feb 2015. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-1831 in the wild and no public exploit code.

Affected packages and fixed versions:
- passenger (RubyGems): affected all versions; fixed in 4.0.38
- passenger (RubyGems): affected all versions; fixed in 4.0.38

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-1831/ (Markdown: https://insights.sbomify.com/CVE-2014-1831/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-1831
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-1831
- OSV: https://osv.dev/vulnerability/CVE-2014-1831

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-1831/
Summaries are generated and may contain mistakes; the official description above is the record.
