{"answers":{"affected":"2 open source packages ship an affected version, including impresscms/impresscms. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-1836 exists.","fix":"Upgrade impresscms/impresscms to 1.3.6 or later.","what":"CVE-2014-1836 is a medium-severity path traversal vulnerability in n/a, published on 1 Jul 2015. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-1836 and fix it if it is affected.\n\nWhat it is: CVE-2014-1836 is a medium-severity path traversal vulnerability in n/a, published on 1 Jul 2015. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-1836 exists.\n\nAffected packages and fixed versions:\n- impresscms/impresscms (Packagist): affected all versions; fixed in 1.3.6\n- impresscms/impresscms (Packagist): affected all versions; fixed in 1.3.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-1836/ (Markdown: https://insights.sbomify.com/CVE-2014-1836/index.md)","id":"CVE-2014-1836","markdown":"https://insights.sbomify.com/CVE-2014-1836/index.md","name":"CVE-2014-1836","record":{"aliases":["GHSA-wcj4-ff9m-5r7g"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"ImpressCMS","requires_auth":"low_privilege","summary":"Remote attackers can delete arbitrary files on the server via path traversal in the image editor, requiring low privileges.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"impresscms","vendor":"impresscms"}],"cvss":{"score":6.4,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Absolute path traversal vulnerability in htdocs/libraries/image-editor/image-edit.php in ImpressCMS before 1.3.6 allows remote attackers to delete arbitrary files via a full pathname in the image_path parameter in a cancel action.","ecosystems":["Packagist"],"exploits":{"exploitdb":1,"first_seen":"2014-02-05","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2014-02-05","kind":"exploitdb","ref":"31431","stars":null,"title":"ImpressCMS 1.3.5 - Multiple Vulnerabilities"}],"tier":"weaponised"},"has_fix":true,"headline":"ImpressCMS Path Traversal to Arbitrary File Delete","id":"CVE-2014-1836","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"path_traversal","year":"2014"},"n_packages":2,"n_references":5,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2014-1837"},"packages":[{"ecosystem":"Packagist","fixed":["1.3.6"],"introduced":["0"],"last_affected":[],"package":"impresscms/impresscms","purl":null,"source":"GHSA-wcj4-ff9m-5r7g"},{"ecosystem":"Packagist","fixed":["1.3.6"],"introduced":["0"],"last_affected":[],"package":"impresscms/impresscms","purl":"pkg:composer/impresscms/impresscms","source":"GHSA-wcj4-ff9m-5r7g"}],"prev":{"headline":"Echor Ruby Gem credentials can be stolen via process table monitoring","id":"CVE-2014-1835"},"products":["n/a"],"published":"2015-07-01","related":[{"cvss_score":10,"headline":"Multiple unspecified vulnerabilities in ImpressCMS 1.0 have unknown impact and attack vectors, related to modules/admin.php and \"a few files","id":"CVE-2008-3453","kev_date_added":null,"published":"2008-08-04"},{"cvss_score":9.8,"headline":"SQL Injection in ImpressCMS","id":"CVE-2021-26599","kev_date_added":null,"published":"2022-03-28"},{"cvss_score":9.8,"headline":"Type Confusion in ImpressCMS","id":"CVE-2021-26600","kev_date_added":null,"published":"2022-03-28"},{"cvss_score":9.8,"headline":"Path Traversal in ImpressCMS","id":"CVE-2022-24977","kev_date_added":null,"published":"2022-02-13"},{"cvss_score":9.3,"headline":"ImpressCMS 1.4.4 - Unrestricted File Upload","id":"CVE-2022-50912","kev_date_added":null,"published":"2026-01-13"},{"cvss_score":8.1,"headline":"Path Traversal in ImpressCMS","id":"CVE-2021-26601","kev_date_added":null,"published":"2022-03-28"},{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2010-4271","kev_date_added":null,"published":"2010-11-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can delete arbitrary files on the server via path traversal in the image editor, requiring low privileges.","url":"https://insights.sbomify.com/CVE-2014-1836/"}