# CVE-2014-1836: ImpressCMS Path Traversal to Arbitrary File Delete

> Remote attackers can delete arbitrary files on the server via path traversal in the image editor, requiring low privileges.

- **Severity:** Medium 6.4 (`AV:N/AC:L/Au:N/C:N/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jul 2015
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-wcj4-ff9m-5r7g

## What is CVE-2014-1836?

CVE-2014-1836 is a medium-severity path traversal vulnerability in n/a, published on 1 Jul 2015. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Absolute path traversal vulnerability in htdocs/libraries/image-editor/image-edit.php in ImpressCMS before 1.3.6 allows remote attackers to delete arbitrary files via a full pathname in the image_path parameter in a cancel action.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2014-1836?

2 open source packages ship an affected version, including impresscms/impresscms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `impresscms/impresscms` | Packagist | All versions | 1.3.6 |
| `impresscms/impresscms` | Packagist | All versions | 1.3.6 |

Products: Impresscms Impresscms.

## How do I fix CVE-2014-1836?

Upgrade impresscms/impresscms to 1.3.6 or later.

## Is CVE-2014-1836 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-1836 exists.

Public exploit code:

- ImpressCMS 1.3.5 - Multiple Vulnerabilities (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2008-3453](https://insights.sbomify.com/CVE-2008-3453/): Multiple unspecified vulnerabilities in ImpressCMS 1.0 have unknown impact and attack vectors, related to modules/admin.php and "a few files (critical 10.0)
- [CVE-2021-26599](https://insights.sbomify.com/CVE-2021-26599/): SQL Injection in ImpressCMS (critical 9.8)
- [CVE-2021-26600](https://insights.sbomify.com/CVE-2021-26600/): Type Confusion in ImpressCMS (critical 9.8)
- [CVE-2022-24977](https://insights.sbomify.com/CVE-2022-24977/): Path Traversal in ImpressCMS (critical 9.8)
- [CVE-2022-50912](https://insights.sbomify.com/CVE-2022-50912/): ImpressCMS 1.4.4 - Unrestricted File Upload (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-1836 and fix it if it is affected.

What it is: CVE-2014-1836 is a medium-severity path traversal vulnerability in n/a, published on 1 Jul 2015. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-1836 exists.

Affected packages and fixed versions:
- impresscms/impresscms (Packagist): affected all versions; fixed in 1.3.6
- impresscms/impresscms (Packagist): affected all versions; fixed in 1.3.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-1836/ (Markdown: https://insights.sbomify.com/CVE-2014-1836/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-1836
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-1836
- OSV: https://osv.dev/vulnerability/CVE-2014-1836

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-1836/
Summaries are generated and may contain mistakes; the official description above is the record.
