CVE-2014-1838 Improper Link Resolution Before File Access in logilab-commons

Medium 4.4 Published Updated

Local attackers can overwrite arbitrary files via symlink attacks in logilab-commons PDF functions, requiring library upgrade.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2014-1838?

CVE-2014-1838 is a medium-severity path traversal vulnerability in Opensuse Opensuse, published on 11 Mar 2014. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

The (1) extract_keys_from_pdf and (2) fill_pdf functions in pdf_ext.py in logilab-commons before 0.61.0 allows local users to overwrite arbitrary files and possibly have other unspecified impact via a symlink attack on /tmp/toto.fdf.

Weakness: CWE-59

Which versions are affected by CVE-2014-1838?

3 open source packages ship an affected version, including logilab-common. It affects 2 products.

PackageAffectedFixed in
logilab-common PyPIAll versions0.60.1
logilab-common PyPIAll versions0.61.0
logilab-common PyPIAll versions0.61.0

Products include Logilab Logilab-Common, Opensuse Opensuse.

How do I fix CVE-2014-1838?

Upgrade logilab-common to a fixed version for your release line: 0.60.1 or 0.61.0.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2014-1838 being exploited?

There is no known exploitation of CVE-2014-1838 in the wild and no public exploit code.

All Opensuse Opensuse vulnerabilities

Sources

Also known as DEBIAN-CVE-2014-1838, GHSA-rr52-wg7f-8875, PYSEC-2014-83.

Is CVE-2014-1838 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free