{"answers":{"affected":"3 open source packages ship an affected version, including logilab-common. It affects 2 products.","exploited":"There is no known exploitation of CVE-2014-1838 in the wild and no public exploit code.","fix":"Upgrade logilab-common to a fixed version for your release line: 0.60.1 or 0.61.0.","what":"CVE-2014-1838 is a medium-severity path traversal vulnerability in Opensuse Opensuse, published on 11 Mar 2014. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-1838 and fix it if it is affected.\n\nWhat it is: CVE-2014-1838 is a medium-severity path traversal vulnerability in Opensuse Opensuse, published on 11 Mar 2014. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-1838 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- logilab-common (PyPI): affected all versions; fixed in 0.60.1\n- logilab-common (PyPI): affected all versions; fixed in 0.61.0\n- logilab-common (PyPI): affected all versions; fixed in 0.61.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-1838/ (Markdown: https://insights.sbomify.com/CVE-2014-1838/index.md)","id":"CVE-2014-1838","markdown":"https://insights.sbomify.com/CVE-2014-1838/index.md","name":"CVE-2014-1838","record":{"aliases":["DEBIAN-CVE-2014-1838","GHSA-rr52-wg7f-8875","PYSEC-2014-83"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","other"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python PDF library","requires_auth":"none","summary":"Local attackers can overwrite arbitrary files via symlink attacks in logilab-commons PDF functions, requiring library upgrade.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"logilab-common","vendor":"logilab"},{"product":"opensuse","vendor":"opensuse"}],"cvss":{"score":4.4,"severity":"medium","source":"nvd","vector":"AV:L/AC:M/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-59","name":"Improper Link Resolution Before File Access"}],"description":"The (1) extract_keys_from_pdf and (2) fill_pdf functions in pdf_ext.py in logilab-commons before 0.61.0 allows local users to overwrite arbitrary files and possibly have other unspecified impact via a symlink attack on /tmp/toto.fdf.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Link Resolution Before File Access in logilab-commons","id":"CVE-2014-1838","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"opensuse:opensuse","products":["opensuse:opensuse"],"type":"path_traversal","year":"2014"},"n_packages":3,"n_references":5,"next":{"headline":"Creation of Temporary File With Insecure Permissions in logilab-commons","id":"CVE-2014-1839"},"packages":[{"ecosystem":"PyPI","fixed":["0.60.1"],"introduced":["0"],"last_affected":[],"package":"logilab-common","purl":"pkg:pypi/logilab-common","source":"PYSEC-2014-83"},{"ecosystem":"PyPI","fixed":["0.61.0"],"introduced":["0"],"last_affected":[],"package":"logilab-common","purl":null,"source":"GHSA-rr52-wg7f-8875"},{"ecosystem":"PyPI","fixed":["0.61.0"],"introduced":["0"],"last_affected":[],"package":"logilab-common","purl":"pkg:pypi/logilab-common","source":"GHSA-rr52-wg7f-8875"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2014-1837"},"products":["n/a"],"published":"2014-03-11","related":[{"cvss_score":4.4,"headline":"Creation of Temporary File With Insecure Permissions in logilab-commons","id":"CVE-2014-1839","kev_date_added":null,"published":"2014-03-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Local attackers can overwrite arbitrary files via symlink attacks in logilab-commons PDF functions, requiring library upgrade.","url":"https://insights.sbomify.com/CVE-2014-1838/"}