# CVE-2014-1839: Creation of Temporary File With Insecure Permissions in logilab-commons

> Local attackers can exploit a race condition in temporary file creation to modify data or execute code via the logilab-commons library.

- **Severity:** Medium 4.4 (`AV:L/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Mar 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-1839, GHSA-g5m2-22h2-rr3j, PYSEC-2014-84

## What is CVE-2014-1839?

CVE-2014-1839 is a medium-severity vulnerability in Opensuse Opensuse, published on 11 Mar 2014. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The Execute class in shellutils in logilab-commons before 0.61.0 uses tempfile.mktemp, which allows local users to have an unspecified impact by pre-creating the temporary file.

## Which versions are affected by CVE-2014-1839?

3 open source packages ship an affected version, including logilab-common. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `logilab-common` | PyPI | All versions | 0.60.1 |
| `logilab-common` | PyPI | All versions | 0.61.0 |
| `logilab-common` | PyPI | All versions | 0.61.0 |

Products: Logilab Logilab-Common, Opensuse Opensuse.

## How do I fix CVE-2014-1839?

Upgrade logilab-common to a fixed version for your release line: 0.60.1 or 0.61.0.

## Is CVE-2014-1839 being exploited?

There is no known exploitation of CVE-2014-1839 in the wild and no public exploit code.

## Other vulnerabilities in Opensuse Opensuse

- [CVE-2014-1838](https://insights.sbomify.com/CVE-2014-1838/): Improper Link Resolution Before File Access in logilab-commons (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-1839 and fix it if it is affected.

What it is: CVE-2014-1839 is a medium-severity vulnerability in Opensuse Opensuse, published on 11 Mar 2014. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-1839 in the wild and no public exploit code.

Affected packages and fixed versions:
- logilab-common (PyPI): affected all versions; fixed in 0.60.1
- logilab-common (PyPI): affected all versions; fixed in 0.61.0
- logilab-common (PyPI): affected all versions; fixed in 0.61.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-1839/ (Markdown: https://insights.sbomify.com/CVE-2014-1839/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-1839
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-1839
- OSV: https://osv.dev/vulnerability/CVE-2014-1839

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-1839/
Summaries are generated and may contain mistakes; the official description above is the record.
