{"answers":{"affected":"2 open source packages ship an affected version, including org.restlet.jse:org.restlet. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-1868 in the wild and no public exploit code.","fix":"Upgrade org.restlet.jse:org.restlet to 2.1.7 or later.","what":"CVE-2014-1868 is a medium-severity vulnerability in n/a, published on 6 Oct 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-1868 and fix it if it is affected.\n\nWhat it is: CVE-2014-1868 is a medium-severity vulnerability in n/a, published on 6 Oct 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-1868 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.restlet.jse:org.restlet (Maven): affected from 2.1.0; fixed in 2.1.7\n- org.restlet.jse:org.restlet (Maven): affected from 2.1.0; fixed in 2.1.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-1868/ (Markdown: https://insights.sbomify.com/CVE-2014-1868/index.md)","id":"CVE-2014-1868","markdown":"https://insights.sbomify.com/CVE-2014-1868/index.md","name":"CVE-2014-1868","record":{"aliases":["GHSA-73cq-fhp3-8rpw","UBUNTU-CVE-2014-1868"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Java REST framework","requires_auth":"none","summary":"Attackers can cause denial of service in Restlet Framework via XML Entity Expansion when XML representations are used.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"restlet_framework","vendor":"restlet"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[],"description":"Restlet Framework 2.1.x before 2.1.7 and 2.x.x before 2.2 RC1, when using XMLRepresentation or XML serializers, allows attackers to cause a denial of service via an XML Entity Expansion (XEE) attack.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moderate severity vulnerability that affects org.restlet.jse:org.restlet","id":"CVE-2014-1868","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2014"},"n_packages":2,"n_references":3,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2014-1869"},"packages":[{"ecosystem":"Maven","fixed":["2.1.7"],"introduced":["2.1.0"],"last_affected":[],"package":"org.restlet.jse:org.restlet","purl":null,"source":"GHSA-73cq-fhp3-8rpw"},{"ecosystem":"Maven","fixed":["2.1.7"],"introduced":["2.1.0"],"last_affected":[],"package":"org.restlet.jse:org.restlet","purl":"pkg:maven/org.restlet.jse/org.restlet","source":"GHSA-73cq-fhp3-8rpw"}],"prev":{"headline":"Security feature bypass in suphp","id":"CVE-2014-1867"},"products":["n/a"],"published":"2014-10-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Attackers can cause denial of service in Restlet Framework via XML Entity Expansion when XML representations are used.","url":"https://insights.sbomify.com/CVE-2014-1868/"}