{"answers":{"affected":"3 open source packages ship an affected version, including python-gnupg. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-1927 in the wild and no public exploit code.","fix":"Upgrade python-gnupg to 0.3.6 or later.","what":"CVE-2014-1927 is a high-severity command injection vulnerability in n/a, published on 25 Oct 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-1927 and fix it if it is affected.\n\nWhat it is: CVE-2014-1927 is a high-severity command injection vulnerability in n/a, published on 25 Oct 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-1927 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- python-gnupg (PyPI): affected from 0.3.5; fixed in 0.3.6\n- python-gnupg (PyPI): affected from 0.3.5; fixed in 0.3.6\n- python-gnupg (PyPI): affected from 0.3.5; fixed in 0.3.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-1927/ (Markdown: https://insights.sbomify.com/CVE-2014-1927/index.md)","id":"CVE-2014-1927","markdown":"https://insights.sbomify.com/CVE-2014-1927/index.md","name":"CVE-2014-1927","record":{"aliases":["DEBIAN-CVE-2014-1927","GHSA-r3vr-prwv-86g9","PYSEC-2014-90","UBUNTU-CVE-2014-1927"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python GnuPG library","requires_auth":"none","summary":"Attackers can execute arbitrary code via shell metacharacters in the python-gnupg library due to improper string quoting.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"python-gnupg","vendor":"python-gnupg_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"The shell_quote function in python-gnupg 0.3.5 does not properly quote strings, which allows context-dependent attackers to execute arbitrary code via shell metacharacters in unspecified vectors, as demonstrated using \"$(\" command-substitution sequences, a different vulnerability than CVE-2014-1928.  NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"python-gnupg's shell_quote function does not properly quote strings","id":"CVE-2014-1927","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2014"},"n_packages":3,"n_references":7,"next":{"headline":"python-gnupg's shell_quote function does not properly escape characters","id":"CVE-2014-1928"},"packages":[{"ecosystem":"PyPI","fixed":["0.3.6"],"introduced":["0.3.5"],"last_affected":[],"package":"python-gnupg","purl":null,"source":"GHSA-r3vr-prwv-86g9"},{"ecosystem":"PyPI","fixed":["0.3.6"],"introduced":["0.3.5"],"last_affected":[],"package":"python-gnupg","purl":"pkg:pypi/python-gnupg","source":"GHSA-r3vr-prwv-86g9"},{"ecosystem":"PyPI","fixed":["0.3.6"],"introduced":["0.3.5"],"last_affected":[],"package":"python-gnupg","purl":"pkg:pypi/python-gnupg","source":"PYSEC-2014-90"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2014-1926"},"products":["n/a"],"published":"2014-10-25","related":[{"cvss_score":4.6,"headline":"python-gnupg's shell_quote function does not properly escape characters","id":"CVE-2014-1928","kev_date_added":null,"published":"2014-10-25"},{"cvss_score":4.4,"headline":"python-gnupg vulnerable to shell injection","id":"CVE-2014-1929","kev_date_added":null,"published":"2014-10-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via shell metacharacters in the python-gnupg library due to improper string quoting.","url":"https://insights.sbomify.com/CVE-2014-1927/"}