# CVE-2014-1929: python-gnupg vulnerable to shell injection

> Attackers can inject commands via positional arguments in python-gnupg, potentially leading to code execution.

- **Severity:** Medium 4.4 (`AV:L/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Oct 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-1929, GHSA-vcr5-xr9h-mvc5, PYSEC-2014-92

## What is CVE-2014-1929?

CVE-2014-1929 is a medium-severity command injection vulnerability in n/a, published on 25 Oct 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

python-gnupg 0.3.5 and 0.3.6 allows context-dependent attackers to have an unspecified impact via vectors related to "option injection through positional arguments." NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7323.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2014-1929?

3 open source packages ship an affected version, including python-gnupg. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `python-gnupg` | PyPI | From 0.3.5 | 0.3.7 |
| `python-gnupg` | PyPI | From 0.3.5 | 0.3.7 |
| `python-gnupg` | PyPI | From 0.3.5 | 0.3.7 |

Products: Python-Gnupg Project Python-Gnupg.

## How do I fix CVE-2014-1929?

Upgrade python-gnupg to 0.3.7 or later.

## Is CVE-2014-1929 being exploited?

There is no known exploitation of CVE-2014-1929 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2014-1927](https://insights.sbomify.com/CVE-2014-1927/): python-gnupg's shell_quote function does not properly quote strings (high 7.5)
- [CVE-2014-1928](https://insights.sbomify.com/CVE-2014-1928/): python-gnupg's shell_quote function does not properly escape characters (medium 4.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-1929 and fix it if it is affected.

What it is: CVE-2014-1929 is a medium-severity command injection vulnerability in n/a, published on 25 Oct 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-1929 in the wild and no public exploit code.

Affected packages and fixed versions:
- python-gnupg (PyPI): affected from 0.3.5; fixed in 0.3.7
- python-gnupg (PyPI): affected from 0.3.5; fixed in 0.3.7
- python-gnupg (PyPI): affected from 0.3.5; fixed in 0.3.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-1929/ (Markdown: https://insights.sbomify.com/CVE-2014-1929/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-1929
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-1929
- OSV: https://osv.dev/vulnerability/CVE-2014-1929

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-1929/
Summaries are generated and may contain mistakes; the official description above is the record.
