# CVE-2014-1932: PIL and Pillow Vulnerable to Symlink Attack on Tmpfiles

> Local attackers can overwrite arbitrary files and read sensitive data via symlink attacks on temporary files in PIL and Pillow.

- **Severity:** Medium 4.4 (`AV:L/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Apr 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-1932, GHSA-x895-2wrm-hvp7, PYSEC-2014-22

## What is CVE-2014-1932?

CVE-2014-1932 is a medium-severity path traversal vulnerability in Python Pillow, published on 17 Apr 2014. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

The (1) load_djpeg function in JpegImagePlugin.py, (2) Ghostscript function in EpsImagePlugin.py, (3) load function in IptcImagePlugin.py, and (4) _copy function in Image.py in Python Image Library (PIL) 1.1.7 and earlier and Pillow before 2.3.1 do not properly create temporary files, which allow local users to overwrite arbitrary files and obtain sensitive information via a symlink attack on the temporary file.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2014-1932?

3 open source packages ship an affected version, including pillow. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pillow` | PyPI | All versions | 2.3.1 |
| `pillow` | PyPI | All versions | 2.3.1 |
| `pillow` | PyPI | All versions | 2.3.1 |

Products: Python Pillow, Pythonware Python Imaging Library.

## How do I fix CVE-2014-1932?

Upgrade pillow to 2.3.1 or later.

## Is CVE-2014-1932 being exploited?

There is no known exploitation of CVE-2014-1932 in the wild and no public exploit code.

## Other vulnerabilities in Python Pillow

- [CVE-2014-3007](https://insights.sbomify.com/CVE-2014-3007/): Pillow command injection (critical 10.0)
- [CVE-2026-96639](https://insights.sbomify.com/CVE-2026-96639/): Pillow multi-frame loaders can reuse stale native image storage after mode transitions (critical 9.8)
- [CVE-2022-30595](https://insights.sbomify.com/CVE-2022-30595/): Buffer over-flow in Pillow (critical 9.8)
- [CVE-2021-25289](https://insights.sbomify.com/CVE-2021-25289/): Out of bounds write in Pillow (critical 9.8)
- [CVE-2016-4009](https://insights.sbomify.com/CVE-2016-4009/): Pillow Integer overflow in ImagingResampleHorizontal (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-1932 and fix it if it is affected.

What it is: CVE-2014-1932 is a medium-severity path traversal vulnerability in Python Pillow, published on 17 Apr 2014. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2014-1932 in the wild and no public exploit code.

Affected packages and fixed versions:
- pillow (PyPI): affected all versions; fixed in 2.3.1
- pillow (PyPI): affected all versions; fixed in 2.3.1
- pillow (PyPI): affected all versions; fixed in 2.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-1932/ (Markdown: https://insights.sbomify.com/CVE-2014-1932/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-1932
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-1932
- OSV: https://osv.dev/vulnerability/CVE-2014-1932

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-1932/
Summaries are generated and may contain mistakes; the official description above is the record.
