# CVE-2014-1938: Link Following in rply

> The rply library creates temporary files insecurely, allowing attackers to overwrite files or escalate privileges via symlink attacks.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Nov 2019
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-1938, GHSA-m8qc-mf6p-pfq9, PYSEC-2019-202, UBUNTU-CVE-2014-1938

## What is CVE-2014-1938?

CVE-2014-1938 is a medium-severity path traversal vulnerability in n/a, published on 21 Nov 2019. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

python-rply before 0.7.4 insecurely creates temporary files.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2014-1938?

3 open source packages ship an affected version, including rply. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rply` | PyPI | All versions | 0.7.4 |
| `rply` | PyPI | All versions | 0.7.4 |
| `rply` | PyPI | All versions | 0.7.4 |

Products: Rply Project Rply.

## How do I fix CVE-2014-1938?

Upgrade rply to 0.7.4 or later.

## Is CVE-2014-1938 being exploited?

There is no known exploitation of CVE-2014-1938 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-1938 and fix it if it is affected.

What it is: CVE-2014-1938 is a medium-severity path traversal vulnerability in n/a, published on 21 Nov 2019. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-1938 in the wild and no public exploit code.

Affected packages and fixed versions:
- rply (PyPI): affected all versions; fixed in 0.7.4
- rply (PyPI): affected all versions; fixed in 0.7.4
- rply (PyPI): affected all versions; fixed in 0.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-1938/ (Markdown: https://insights.sbomify.com/CVE-2014-1938/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-1938
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-1938
- OSV: https://osv.dev/vulnerability/CVE-2014-1938

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-1938/
Summaries are generated and may contain mistakes; the official description above is the record.
