{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.tapestry:tapestry-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-1972 in the wild and no public exploit code.","fix":"Upgrade org.apache.tapestry:tapestry-core to 5.3.6 or later.","what":"CVE-2014-1972 is a high-severity unsafe deserialization vulnerability in n/a, published on 22 Aug 2015. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-1972 and fix it if it is affected.\n\nWhat it is: CVE-2014-1972 is a high-severity unsafe deserialization vulnerability in n/a, published on 22 Aug 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-1972 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.tapestry:tapestry-core (Maven): affected all versions; fixed in 5.3.6\n- org.apache.tapestry:tapestry-core (Maven): affected all versions; fixed in 5.3.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-1972/ (Markdown: https://insights.sbomify.com/CVE-2014-1972/index.md)","id":"CVE-2014-1972","markdown":"https://insights.sbomify.com/CVE-2014-1972/index.md","name":"CVE-2014-1972","record":{"aliases":["GHSA-c438-8cvq-pxxx"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Java web framework","requires_auth":"none","summary":"Remote attackers can execute arbitrary code or cause denial of service via crafted serialized data in Apache Tapestry.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jpcert","cpe":[{"product":"tapestry","vendor":"apache"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:N/A:C","version":"2.0"},"cwes":[{"id":"CWE-399","name":null}],"description":"Apache Tapestry before 5.3.6 relies on client-side object storage without checking whether a client has modified an object, which allows remote attackers to cause a denial of service (resource consumption) or execute arbitrary code via crafted serialized data.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Tapestry Unsafe Object Storage","id":"CVE-2014-1972","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2014"},"n_packages":2,"n_references":10,"next":{"headline":"Path traversal in n/a","id":"CVE-2014-1973"},"packages":[{"ecosystem":"Maven","fixed":["5.3.6"],"introduced":["0"],"last_affected":[],"package":"org.apache.tapestry:tapestry-core","purl":null,"source":"GHSA-c438-8cvq-pxxx"},{"ecosystem":"Maven","fixed":["5.3.6"],"introduced":["0"],"last_affected":[],"package":"org.apache.tapestry:tapestry-core","purl":"pkg:maven/org.apache.tapestry/tapestry-core","source":"GHSA-c438-8cvq-pxxx"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2014-1971"},"products":["n/a"],"published":"2015-08-22","related":[{"cvss_score":9.8,"headline":"Apache Tapestry prior to version 4 (EOL) allows RCE though deserialization of untrusted input","id":"CVE-2022-46366","kev_date_added":null,"published":"2022-12-02"},{"cvss_score":9.8,"headline":"Bypass of the fix for CVE-2019-0195","id":"CVE-2021-27850","kev_date_added":null,"published":"2021-04-15"},{"cvss_score":9.8,"headline":"Deserialization flaw in EOL Tapestry 4.","id":"CVE-2020-17531","kev_date_added":null,"published":"2020-12-08"},{"cvss_score":9.8,"headline":"Deserialization of Untrusted Data in Apache Tapestry","id":"CVE-2019-0195","kev_date_added":null,"published":"2019-09-16"},{"cvss_score":9.8,"headline":"Timing attack on HMAC signature comparison in Apache Tapestry","id":"CVE-2019-10071","kev_date_added":null,"published":"2019-09-16"},{"cvss_score":7.5,"headline":"Apache Tapestry: Possible classpath file download through URL manipulation","id":"CVE-2026-61899","kev_date_added":null,"published":"2026-08-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code or cause denial of service via crafted serialized data in Apache Tapestry.","url":"https://insights.sbomify.com/CVE-2014-1972/"}