# CVE-2014-1972: Apache Tapestry Unsafe Object Storage

> Remote attackers can execute arbitrary code or cause denial of service via crafted serialized data in Apache Tapestry.

- **Severity:** High 7.8 (`AV:N/AC:L/Au:N/C:N/I:N/A:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Aug 2015
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-c438-8cvq-pxxx

## What is CVE-2014-1972?

CVE-2014-1972 is a high-severity unsafe deserialization vulnerability in n/a, published on 22 Aug 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Tapestry before 5.3.6 relies on client-side object storage without checking whether a client has modified an object, which allows remote attackers to cause a denial of service (resource consumption) or execute arbitrary code via crafted serialized data.

Weakness: CWE-399

## Which versions are affected by CVE-2014-1972?

2 open source packages ship an affected version, including org.apache.tapestry:tapestry-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tapestry:tapestry-core` | Maven | All versions | 5.3.6 |
| `org.apache.tapestry:tapestry-core` | Maven | All versions | 5.3.6 |

Products: Apache Tapestry.

## How do I fix CVE-2014-1972?

Upgrade org.apache.tapestry:tapestry-core to 5.3.6 or later.

## Is CVE-2014-1972 being exploited?

There is no known exploitation of CVE-2014-1972 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-46366](https://insights.sbomify.com/CVE-2022-46366/): Apache Tapestry prior to version 4 (EOL) allows RCE though deserialization of untrusted input (critical 9.8)
- [CVE-2021-27850](https://insights.sbomify.com/CVE-2021-27850/): Bypass of the fix for CVE-2019-0195 (critical 9.8)
- [CVE-2020-17531](https://insights.sbomify.com/CVE-2020-17531/): Deserialization flaw in EOL Tapestry 4. (critical 9.8)
- [CVE-2019-0195](https://insights.sbomify.com/CVE-2019-0195/): Deserialization of Untrusted Data in Apache Tapestry (critical 9.8)
- [CVE-2019-10071](https://insights.sbomify.com/CVE-2019-10071/): Timing attack on HMAC signature comparison in Apache Tapestry (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-1972 and fix it if it is affected.

What it is: CVE-2014-1972 is a high-severity unsafe deserialization vulnerability in n/a, published on 22 Aug 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-1972 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tapestry:tapestry-core (Maven): affected all versions; fixed in 5.3.6
- org.apache.tapestry:tapestry-core (Maven): affected all versions; fixed in 5.3.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-1972/ (Markdown: https://insights.sbomify.com/CVE-2014-1972/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-1972
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-1972
- OSV: https://osv.dev/vulnerability/CVE-2014-1972

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-1972/
Summaries are generated and may contain mistakes; the official description above is the record.
