{"answers":{"affected":"2 open source packages ship an affected version, including james-heinrich/getid3. It affects 2 products.","exploited":"There is no known exploitation of CVE-2014-2053 in the wild and no public exploit code.","fix":"Upgrade james-heinrich/getid3 to 1.9.9 or later.","what":"CVE-2014-2053 is a high-severity vulnerability in Owncloud Owncloud Server, published on 4 Jun 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-2053 and fix it if it is affected.\n\nWhat it is: CVE-2014-2053 is a high-severity vulnerability in Owncloud Owncloud Server, published on 4 Jun 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-2053 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- james-heinrich/getid3 (Packagist): affected all versions; fixed in 1.9.9\n- james-heinrich/getid3 (Packagist): affected all versions; fixed in 1.9.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-2053/ (Markdown: https://insights.sbomify.com/CVE-2014-2053/index.md)","id":"CVE-2014-2053","markdown":"https://insights.sbomify.com/CVE-2014-2053/index.md","name":"CVE-2014-2053","record":{"aliases":["DEBIAN-CVE-2014-2053","GHSA-5v43-55m5-qr8f"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP media library","requires_auth":"none","summary":"Remote attackers can read arbitrary files or cause denial of service via XML External Entity attacks in the getID3 library.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"getid3","vendor":"getid3"},{"product":"owncloud_server","vendor":"owncloud"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[],"description":"getID3() before 1.9.8, as used in ownCloud Server before 5.0.15 and 6.0.x before 6.0.2, allows remote attackers to read arbitrary files, cause a denial of service, or possibly have other impact via an XML External Entity (XXE) attack.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"getID3 is vulnerable to XML External Entity (XXE)","id":"CVE-2014-2053","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"owncloud:owncloud_server","products":["owncloud:owncloud_server"],"type":"xxe","year":"2014"},"n_packages":2,"n_references":5,"next":{"headline":"PHPExcel vulnerable to XXE attacks through libxml","id":"CVE-2014-2054"},"packages":[{"ecosystem":"Packagist","fixed":["1.9.9"],"introduced":["0"],"last_affected":[],"package":"james-heinrich/getid3","purl":null,"source":"GHSA-5v43-55m5-qr8f"},{"ecosystem":"Packagist","fixed":["1.9.9"],"introduced":["0"],"last_affected":[],"package":"james-heinrich/getid3","purl":"pkg:composer/james-heinrich/getid3","source":"GHSA-5v43-55m5-qr8f"}],"prev":{"headline":"XML external entity in n/a","id":"CVE-2014-2052"},"products":["n/a"],"published":"2014-06-04","related":[{"cvss_score":6.1,"headline":"Cross-site scripting in demos/demo.mysqli.php in getID3","id":"CVE-2021-40926","kev_date_added":null,"published":"2021-10-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can read arbitrary files or cause denial of service via XML External Entity attacks in the getID3 library.","url":"https://insights.sbomify.com/CVE-2014-2053/"}