CVE-2014-2055 XXE in SabreDAV

High 7.5 Published Updated

Remote attackers can read arbitrary files or cause denial of service via XML External Entity attacks in SabreDAV.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2014-2055?

CVE-2014-2055 is a high-severity vulnerability in Owncloud Owncloud Server, published on 4 Jun 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

SabreDAV before 1.7.11, as used in ownCloud Server before 5.0.15 and 6.0.x before 6.0.2, allows remote attackers to read arbitrary files, cause a denial of service, or possibly have other impact via an XML External Entity (XXE) attack.

Which versions are affected by CVE-2014-2055?

4 open source packages ship an affected version, including sabre/dav. It affects 2 products.

PackageAffectedFixed in
sabre/dav PackagistFrom 1.6.01.7.11
sabre/dav PackagistFrom 1.6.01.7.11
sabre/dav PackagistFrom 1.8.01.8.9
sabre/dav PackagistFrom 1.8.01.8.9

Products include Fruux Sabredav, Owncloud Owncloud Server.

How do I fix CVE-2014-2055?

Upgrade sabre/dav to a fixed version for your release line: 1.7.11 or 1.8.9.

Is CVE-2014-2055 being exploited?

There is no known exploitation of CVE-2014-2055 in the wild and no public exploit code.

All Owncloud Owncloud Server vulnerabilities

Sources

Also known as DEBIAN-CVE-2014-2055, GHSA-qm4x-ch5w-gr62.

Is CVE-2014-2055 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free