{"answers":{"affected":"4 open source packages ship an affected version, including sabre/dav. It affects 2 products.","exploited":"There is no known exploitation of CVE-2014-2055 in the wild and no public exploit code.","fix":"Upgrade sabre/dav to a fixed version for your release line: 1.7.11 or 1.8.9.","what":"CVE-2014-2055 is a high-severity vulnerability in Owncloud Owncloud Server, published on 4 Jun 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-2055 and fix it if it is affected.\n\nWhat it is: CVE-2014-2055 is a high-severity vulnerability in Owncloud Owncloud Server, published on 4 Jun 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-2055 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sabre/dav (Packagist): affected from 1.6.0; fixed in 1.7.11\n- sabre/dav (Packagist): affected from 1.6.0; fixed in 1.7.11\n- sabre/dav (Packagist): affected from 1.8.0; fixed in 1.8.9\n- sabre/dav (Packagist): affected from 1.8.0; fixed in 1.8.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-2055/ (Markdown: https://insights.sbomify.com/CVE-2014-2055/index.md)","id":"CVE-2014-2055","markdown":"https://insights.sbomify.com/CVE-2014-2055/index.md","name":"CVE-2014-2055","record":{"aliases":["DEBIAN-CVE-2014-2055","GHSA-qm4x-ch5w-gr62"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"SabreDAV library","requires_auth":"none","summary":"Remote attackers can read arbitrary files or cause denial of service via XML External Entity attacks in SabreDAV.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"sabredav","vendor":"fruux"},{"product":"owncloud_server","vendor":"owncloud"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[],"description":"SabreDAV before 1.7.11, as used in ownCloud Server before 5.0.15 and 6.0.x before 6.0.2, allows remote attackers to read arbitrary files, cause a denial of service, or possibly have other impact via an XML External Entity (XXE) attack.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XXE in SabreDAV","id":"CVE-2014-2055","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"owncloud:owncloud_server","products":["owncloud:owncloud_server"],"type":"xxe","year":"2014"},"n_packages":4,"n_references":2,"next":{"headline":"XML external entity in n/a","id":"CVE-2014-2056"},"packages":[{"ecosystem":"Packagist","fixed":["1.7.11"],"introduced":["1.6.0"],"last_affected":[],"package":"sabre/dav","purl":null,"source":"GHSA-qm4x-ch5w-gr62"},{"ecosystem":"Packagist","fixed":["1.7.11"],"introduced":["1.6.0"],"last_affected":[],"package":"sabre/dav","purl":"pkg:composer/sabre/dav","source":"GHSA-qm4x-ch5w-gr62"},{"ecosystem":"Packagist","fixed":["1.8.9"],"introduced":["1.8.0"],"last_affected":[],"package":"sabre/dav","purl":null,"source":"GHSA-qm4x-ch5w-gr62"},{"ecosystem":"Packagist","fixed":["1.8.9"],"introduced":["1.8.0"],"last_affected":[],"package":"sabre/dav","purl":"pkg:composer/sabre/dav","source":"GHSA-qm4x-ch5w-gr62"}],"prev":{"headline":"PHPExcel vulnerable to XXE attacks through libxml","id":"CVE-2014-2054"},"products":["n/a"],"published":"2014-06-04","related":[{"cvss_score":5,"headline":"SabreDAV Directory Traversal vulnerability","id":"CVE-2013-1939","kev_date_added":null,"published":"2014-03-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can read arbitrary files or cause denial of service via XML External Entity attacks in SabreDAV.","url":"https://insights.sbomify.com/CVE-2014-2055/"}