# CVE-2014-2055: XXE in SabreDAV

> Remote attackers can read arbitrary files or cause denial of service via XML External Entity attacks in SabreDAV.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jun 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-2055, GHSA-qm4x-ch5w-gr62

## What is CVE-2014-2055?

CVE-2014-2055 is a high-severity vulnerability in Owncloud Owncloud Server, published on 4 Jun 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SabreDAV before 1.7.11, as used in ownCloud Server before 5.0.15 and 6.0.x before 6.0.2, allows remote attackers to read arbitrary files, cause a denial of service, or possibly have other impact via an XML External Entity (XXE) attack.

## Which versions are affected by CVE-2014-2055?

4 open source packages ship an affected version, including sabre/dav. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sabre/dav` | Packagist | From 1.6.0 | 1.7.11 |
| `sabre/dav` | Packagist | From 1.6.0 | 1.7.11 |
| `sabre/dav` | Packagist | From 1.8.0 | 1.8.9 |
| `sabre/dav` | Packagist | From 1.8.0 | 1.8.9 |

Products: Fruux Sabredav, Owncloud Owncloud Server.

## How do I fix CVE-2014-2055?

Upgrade sabre/dav to a fixed version for your release line: 1.7.11 or 1.8.9.

## Is CVE-2014-2055 being exploited?

There is no known exploitation of CVE-2014-2055 in the wild and no public exploit code.

## Other vulnerabilities in Owncloud Owncloud Server

- [CVE-2013-1939](https://insights.sbomify.com/CVE-2013-1939/): SabreDAV Directory Traversal vulnerability (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-2055 and fix it if it is affected.

What it is: CVE-2014-2055 is a high-severity vulnerability in Owncloud Owncloud Server, published on 4 Jun 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-2055 in the wild and no public exploit code.

Affected packages and fixed versions:
- sabre/dav (Packagist): affected from 1.6.0; fixed in 1.7.11
- sabre/dav (Packagist): affected from 1.6.0; fixed in 1.7.11
- sabre/dav (Packagist): affected from 1.8.0; fixed in 1.8.9
- sabre/dav (Packagist): affected from 1.8.0; fixed in 1.8.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-2055/ (Markdown: https://insights.sbomify.com/CVE-2014-2055/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-2055
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-2055
- OSV: https://osv.dev/vulnerability/CVE-2014-2055

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-2055/
Summaries are generated and may contain mistakes; the official description above is the record.
