CVE-2014-2058 Jenkins allows attackers to execute arbitrary jobs

Medium 6.5 Published Updated

Authenticated users can bypass access restrictions to execute arbitrary jobs in Jenkins, potentially leading to privilege escalation or code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2014-2058?

CVE-2014-2058 is a medium-severity missing authorization vulnerability in Jenkins Jenkins, published on 17 Oct 2014. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

BuildTrigger in Jenkins before 1.551 and LTS before 1.532.2 allows remote authenticated users to bypass access restrictions and execute arbitrary jobs by configuring a job to trigger another job. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-7330.

Weakness: CWE-264

Which versions are affected by CVE-2014-2058?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.532.2
org.jenkins-ci.main:jenkins-core MavenAll versions1.532.2
org.jenkins-ci.main:jenkins-core MavenFrom 1.5331.551
org.jenkins-ci.main:jenkins-core MavenFrom 1.5331.551

Products include Jenkins Jenkins.

How do I fix CVE-2014-2058?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.532.2 or 1.551.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2014-2058 being exploited?

There is no known exploitation of CVE-2014-2058 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-7fpg-pp3m-h22f.

Is CVE-2014-2058 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free