CVE-2014-2060 Jenkins allows Remote Attackers to Hijack Sessions

Medium 5.0 Published Updated

Remote attackers can hijack sessions in the Jenkins Winstone servlet container, leading to unauthorized account access.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2014-2060?

CVE-2014-2060 is a medium-severity authentication bypass vulnerability in Jenkins Jenkins, published on 17 Oct 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The Winstone servlet container in Jenkins before 1.551 and LTS before 1.532.2 allows remote attackers to hijack sessions via unspecified vectors.

Which versions are affected by CVE-2014-2060?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.532.2
org.jenkins-ci.main:jenkins-core MavenAll versions1.532.2
org.jenkins-ci.main:jenkins-core MavenFrom 1.5331.551
org.jenkins-ci.main:jenkins-core MavenFrom 1.5331.551

Products include Jenkins Jenkins.

How do I fix CVE-2014-2060?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.532.2 or 1.551.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2014-2060 being exploited?

There is no known exploitation of CVE-2014-2060 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-9c26-cf8c-mw43.

Is CVE-2014-2060 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free