CVE-2014-2061 Jenkin allows attackers to obtain passwords by reading the HTML source code

Medium 5.0 Published Updated

Remote attackers can obtain passwords by reading HTML source code due to insecure default values in Jenkins password parameters.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2014-2061?

CVE-2014-2061 is a medium-severity vulnerability in Jenkins Jenkins, published on 17 Oct 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The input control in PasswordParameterDefinition in Jenkins before 1.551 and LTS before 1.532.2 allows remote attackers to obtain passwords by reading the HTML source code, related to the default value.

Weakness: CWE-310

Which versions are affected by CVE-2014-2061?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.532.2
org.jenkins-ci.main:jenkins-core MavenAll versions1.532.2
org.jenkins-ci.main:jenkins-core MavenFrom 1.5331.551
org.jenkins-ci.main:jenkins-core MavenFrom 1.5331.551

Products include Jenkins Jenkins.

How do I fix CVE-2014-2061?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.532.2 or 1.551.

Is CVE-2014-2061 being exploited?

There is no known exploitation of CVE-2014-2061 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-rxfv-gm5x-9wqj.

Is CVE-2014-2061 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free