CVE-2014-2062 Jenkins does not invalidate the API token when a user is deleted

Medium 6.5 Published Updated

Remote authenticated users can retain access via API tokens after account deletion, bypassing authentication controls in Jenkins.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2014-2062?

CVE-2014-2062 is a medium-severity authentication bypass vulnerability in Jenkins Jenkins, published on 17 Oct 2014. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Jenkins before 1.551 and LTS before 1.532.2 does not invalidate the API token when a user is deleted, which allows remote authenticated users to retain access via the token.

Weakness: CWE-287

Which versions are affected by CVE-2014-2062?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.532.2
org.jenkins-ci.main:jenkins-core MavenAll versions1.532.2
org.jenkins-ci.main:jenkins-core MavenFrom 1.5331.551
org.jenkins-ci.main:jenkins-core MavenFrom 1.5331.551

Products include Jenkins Jenkins.

How do I fix CVE-2014-2062?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.532.2 or 1.551.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2014-2062 being exploited?

There is no known exploitation of CVE-2014-2062 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-vxc6-wvh8-fpxw.

Is CVE-2014-2062 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free