CVE-2014-2063 Jenkins Vulnerable to Clickjacking

High 7.5 Published Updated

Remote attackers can perform clickjacking attacks against Jenkins users, potentially bypassing security controls.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2014-2063?

CVE-2014-2063 is a high-severity vulnerability in Jenkins Jenkins, published on 17 Oct 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Jenkins before 1.551 and LTS before 1.532.2 allows remote attackers to conduct clickjacking attacks via unspecified vectors.

Which versions are affected by CVE-2014-2063?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.532.2
org.jenkins-ci.main:jenkins-core MavenAll versions1.532.2
org.jenkins-ci.main:jenkins-core MavenFrom 1.5331.551
org.jenkins-ci.main:jenkins-core MavenFrom 1.5331.551

Products include Jenkins Jenkins.

How do I fix CVE-2014-2063?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.532.2 or 1.551.

Is CVE-2014-2063 being exploited?

There is no known exploitation of CVE-2014-2063 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-w3f5-gq7j-m797.

Is CVE-2014-2063 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free