CVE-2014-2065 Jenkins cross-site scripting (XSS) vulnerability

Medium 4.3 Published Updated

Remote attackers can inject arbitrary web script or HTML via the iconSize cookie, potentially leading to session hijacking or malicious actions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2014-2065?

CVE-2014-2065 is a medium-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 17 Oct 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Cross-site scripting (XSS) vulnerability in Jenkins before 1.551 and LTS before 1.532.2 allows remote attackers to inject arbitrary web script or HTML via the iconSize cookie.

Weakness: CWE-79

Which versions are affected by CVE-2014-2065?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.532.2
org.jenkins-ci.main:jenkins-core MavenAll versions1.532.2
org.jenkins-ci.main:jenkins-core MavenFrom 1.5331.551
org.jenkins-ci.main:jenkins-core MavenFrom 1.5331.551

Products include Jenkins Jenkins.

How do I fix CVE-2014-2065?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.532.2 or 1.551.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2014-2065 being exploited?

There is no known exploitation of CVE-2014-2065 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-fxj8-cqcp-3vgq.

Is CVE-2014-2065 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free