CVE-2014-2067 Jenkins cross-site scripting (XSS) vulnerability
Authenticated users can inject malicious scripts via remote cause notes in Jenkins, potentially compromising other users' sessions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2014-2067?
CVE-2014-2067 is a low-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 28 Feb 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in java/hudson/model/Cause.java in Jenkins before 1.551 and LTS before 1.532.2 allows remote authenticated users to inject arbitrary web script or HTML via a "remote cause note."
Weakness: CWE-79
Which versions are affected by CVE-2014-2067?
4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.jenkins-ci.main:jenkins-core Maven | All versions | 1.532.2 |
org.jenkins-ci.main:jenkins-core Maven | All versions | 1.532.2 |
org.jenkins-ci.main:jenkins-core Maven | From 1.533 | 1.551 |
org.jenkins-ci.main:jenkins-core Maven | From 1.533 | 1.551 |
Products include Jenkins Jenkins.
How do I fix CVE-2014-2067?
Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.532.2 or 1.551.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2014-2067 being exploited?
There is no known exploitation of CVE-2014-2067 in the wild and no public exploit code.
Other vulnerabilities in Jenkins Jenkins
- CVE-2024-23897 Jenkins Command Line Interface (CLI) Path Traversal
- CVE-2018-1000861 Jenkins Stapler Web Framework Deserialization of Untrusted Data
- CVE-2017-1000353 Jenkins Remote Code Execution
- CVE-2015-5317 Jenkins User Interface (UI) Information Disclosure
- CVE-2021-21690 Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins
Sources
Also known as GHSA-vj6q-v2h7-6q5m.