CVE-2014-2068 Jenkins allows attackers to obtain sensitive information

Low 3.5 Published Updated

Authenticated administrators can access sensitive heap dump information via the diagnostics index function in Jenkins.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2014-2068?

CVE-2014-2068 is a low-severity vulnerability in Jenkins Jenkins, published on 17 Oct 2014. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

The doIndex function in hudson/util/RemotingDiagnostics.java in CloudBees Jenkins before 1.551 and LTS before 1.532.2 allows remote authenticated users with the ADMINISTER permission to obtain sensitive information via vectors related to heapDump.

Weakness: CWE-264

Which versions are affected by CVE-2014-2068?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.532.2
org.jenkins-ci.main:jenkins-core MavenAll versions1.532.2
org.jenkins-ci.main:jenkins-core MavenFrom 1.5331.551
org.jenkins-ci.main:jenkins-core MavenFrom 1.5331.551

Products include Jenkins Jenkins.

How do I fix CVE-2014-2068?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.532.2 or 1.551.

Is CVE-2014-2068 being exploited?

There is no known exploitation of CVE-2014-2068 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-pv88-j6rg-r56p.

Is CVE-2014-2068 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free