# CVE-2014-2237: OpenStack Identity (Keystone) Trustee token revocations does not work with memcache backend

> Attackers with trustee privileges can bypass access restrictions by exploiting a flaw in Keystone's memcache token backend that prevents token revocation.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Apr 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-2237, GHSA-23x9-8hxr-978c, PYSEC-2014-105, RHSA-2014:0580

## What is CVE-2014-2237?

CVE-2014-2237 is a medium-severity authentication bypass vulnerability in n/a, published on 1 Apr 2014. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The memcache token backend in OpenStack Identity (Keystone) 2013.1 through 2.013.1.4, 2013.2 through 2013.2.2, and icehouse before icehouse-3, when issuing a trust token with impersonation enabled, does not include this token in the trustee's token-index-list, which prevents the token from being invalidated by bulk token revocation and allows the trustee to bypass intended access restrictions.

Weakness: CWE-264

## Which versions are affected by CVE-2014-2237?

3 open source packages ship an affected version, including keystone. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keystone` | PyPI | All versions | 8.0.0a0 |
| `keystone` | PyPI | All versions | 8.0.0a0 |
| `keystone` | PyPI | All versions | 8.0.0a0 |
| `openstack-keystone` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.3-4.el6ost |
| `openstack-keystone-doc` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.3-4.el6ost |
| `python-keystone` | Red Hat:openstack:4::el6 | All versions | 0:2013.2.3-4.el6ost |

Products: Openstack Keystone.

## How do I fix CVE-2014-2237?

Upgrade keystone to 8.0.0a0 or later.

## Is CVE-2014-2237 being exploited?

There is no known exploitation of CVE-2014-2237 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-12690](https://insights.sbomify.com/CVE-2020-12690/): Insufficient Session Expiration in OpenStack Keystone (high 8.8)
- [CVE-2019-19687](https://insights.sbomify.com/CVE-2019-19687/): OpenStack Keystone Credential Leakage (high 8.8)
- [CVE-2026-43001](https://insights.sbomify.com/CVE-2026-43001/): OpenStack Keystone has an Incorrect Authorization Issue (high 7.9)
- [CVE-2014-2828](https://insights.sbomify.com/CVE-2014-2828/): OpenStack Identity (Keystone) DoS through V3 API authentication chaining (high 7.8)
- [CVE-2021-38155](https://insights.sbomify.com/CVE-2021-38155/): OpenStack Keystone allows information disclosure during account locking (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-2237 and fix it if it is affected.

What it is: CVE-2014-2237 is a medium-severity authentication bypass vulnerability in n/a, published on 1 Apr 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-2237 in the wild and no public exploit code.

Affected packages and fixed versions:
- keystone (PyPI): affected all versions; fixed in 8.0.0a0
- keystone (PyPI): affected all versions; fixed in 8.0.0a0
- keystone (PyPI): affected all versions; fixed in 8.0.0a0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-2237/ (Markdown: https://insights.sbomify.com/CVE-2014-2237/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-2237
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-2237
- OSV: https://osv.dev/vulnerability/CVE-2014-2237

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-2237/
Summaries are generated and may contain mistakes; the official description above is the record.
