# CVE-2014-2383: DOMPDF Arbitrary File Read

> Attackers can read arbitrary files and bypass chroot protections in dompdf when PHP wrappers are enabled via the input_file parameter.

- **Severity:** Medium 6.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Apr 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-2383, GHSA-qr6q-w4gj-3865

## What is CVE-2014-2383?

CVE-2014-2383 is a medium-severity path traversal vulnerability in n/a, published on 28 Apr 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

dompdf.php in dompdf before 0.6.1, when DOMPDF_ENABLE_PHP is enabled, allows context-dependent attackers to bypass chroot protections and read arbitrary files via a PHP protocol and wrappers in the input_file parameter, as demonstrated by a php://filter/read=convert.base64-encode/resource in the input_file parameter.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2014-2383?

2 open source packages ship an affected version, including dompdf/dompdf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dompdf/dompdf` | Packagist | From 0.6.0 | 0.6.1 |
| `dompdf/dompdf` | Packagist | From 0.6.0 | 0.6.1 |

Products: Dompdf Dompdf.

## How do I fix CVE-2014-2383?

Upgrade dompdf/dompdf to 0.6.1 or later.

## Is CVE-2014-2383 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-2383 exists.

Public exploit code:

- https://github.com/Relativ3Pa1n/CVE-2014-2383-LFI-to-RCE-Escalation (github_poc): https://github.com/Relativ3Pa1n/CVE-2014-2383-LFI-to-RCE-Escalation
- dompdf 0.6.0 - 'dompdf.php?read' Arbitrary File Read (exploitdb)
- Dompdf < v0.6.0 - Local File Inclusion (nuclei): http/cves/2014/CVE-2014-2383.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-2383 and fix it if it is affected.

What it is: CVE-2014-2383 is a medium-severity path traversal vulnerability in n/a, published on 28 Apr 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-2383 exists.

Affected packages and fixed versions:
- dompdf/dompdf (Packagist): affected from 0.6.0; fixed in 0.6.1
- dompdf/dompdf (Packagist): affected from 0.6.0; fixed in 0.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-2383/ (Markdown: https://insights.sbomify.com/CVE-2014-2383/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-2383
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-2383
- OSV: https://osv.dev/vulnerability/CVE-2014-2383

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-2383/
Summaries are generated and may contain mistakes; the official description above is the record.
