{"answers":{"affected":"2 open source packages ship an affected version, including rack-ssl. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-2538 in the wild and no public exploit code.","fix":"Upgrade rack-ssl to 1.4.0 or later.","what":"CVE-2014-2538 is a medium-severity cross-site scripting vulnerability in n/a, published on 25 Mar 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2014-2538 and fix it if it is affected.\n\nWhat it is: CVE-2014-2538 is a medium-severity cross-site scripting vulnerability in n/a, published on 25 Mar 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2014-2538 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rack-ssl (RubyGems): affected all versions; fixed in 1.4.0\n- rack-ssl (RubyGems): affected all versions; fixed in 1.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-2538/ (Markdown: https://insights.sbomify.com/CVE-2014-2538/index.md)","id":"CVE-2014-2538","markdown":"https://insights.sbomify.com/CVE-2014-2538/index.md","name":"CVE-2014-2538","record":{"aliases":["DEBIAN-CVE-2014-2538","GHSA-v3rr-cph9-2g2q","MGASA-2014-0156"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby SSL middleware","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via a URI in the rack-ssl gem, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"rack-ssl","vendor":"joshua_peek"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in lib/rack/ssl.rb in the rack-ssl gem before 1.4.0 for Ruby allows remote attackers to inject arbitrary web script or HTML via a URI, which might not be properly handled by third-party adapters such as JRuby-Rack.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"rack-ssl Cross-site Scripting vulnerability","id":"CVE-2014-2538","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2014"},"n_packages":2,"n_references":5,"next":{"headline":"SQL injection in n/a","id":"CVE-2014-2540"},"packages":[{"ecosystem":"RubyGems","fixed":["1.4.0"],"introduced":["0"],"last_affected":[],"package":"rack-ssl","purl":null,"source":"GHSA-v3rr-cph9-2g2q"},{"ecosystem":"RubyGems","fixed":["1.4.0"],"introduced":["0"],"last_affected":[],"package":"rack-ssl","purl":"pkg:gem/rack-ssl","source":"GHSA-v3rr-cph9-2g2q"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2014-2537"},"products":["n/a"],"published":"2014-03-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via a URI in the rack-ssl gem, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2014-2538/"}