CVE-2014-2571 Moodle cross-site scripting (XSS) vulnerability

Low 3.5 Published Updated

Authenticated users can inject arbitrary scripts into Moodle quiz questions, potentially compromising other users' sessions or data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2014-2571?

CVE-2014-2571 is a low-severity cross-site scripting vulnerability in Moodle Moodle, published on 22 Mar 2014. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Cross-site scripting (XSS) vulnerability in the quiz_question_tostring function in mod/quiz/editlib.php in Moodle through 2.3.11, 2.4.x before 2.4.9, 2.5.x before 2.5.5, and 2.6.x before 2.6.2 allows remote authenticated users to inject arbitrary web script or HTML via a quiz question.

Weakness: CWE-79

Which versions are affected by CVE-2014-2571?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistAll versions2.4.9
moodle/moodle PackagistAll versions2.4.9
moodle/moodle PackagistFrom 2.5.02.5.5
moodle/moodle PackagistFrom 2.5.02.5.5
moodle/moodle PackagistFrom 2.6.02.6.2
moodle/moodle PackagistFrom 2.6.02.6.2

Products include Moodle Moodle.

How do I fix CVE-2014-2571?

Upgrade moodle/moodle to a fixed version for your release line: 2.4.9, 2.5.5 or 2.6.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2014-2571 being exploited?

There is no known exploitation of CVE-2014-2571 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-75c6-xqwr-v2r9.

Is CVE-2014-2571 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free