{"answers":{"affected":"2 open source packages ship an affected version, including org.igniterealtime.openfire:parent. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-2741 in the wild and no public exploit code.","fix":"Upgrade org.igniterealtime.openfire:parent to 3.9.2 or later.","what":"CVE-2014-2741 is a high-severity denial of service vulnerability in n/a, published on 11 Apr 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-2741 and fix it if it is affected.\n\nWhat it is: CVE-2014-2741 is a high-severity denial of service vulnerability in n/a, published on 11 Apr 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-2741 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.igniterealtime.openfire:parent (Maven): affected all versions; fixed in 3.9.2\n- org.igniterealtime.openfire:parent (Maven): affected all versions; fixed in 3.9.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-2741/ (Markdown: https://insights.sbomify.com/CVE-2014-2741/index.md)","id":"CVE-2014-2741","markdown":"https://insights.sbomify.com/CVE-2014-2741/index.md","name":"CVE-2014-2741","record":{"aliases":["CVE-2014-0360","GHSA-j5qh-cp3p-2h87"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"XMPP server","requires_auth":"none","summary":"Remote attackers can cause denial of service in Openfire XMPP server via crafted compressed XML streams, requiring an upgrade to mitigate.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"debian","cpe":[{"product":"openfire","vendor":"igniterealtime"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:N/A:C","version":"2.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"nio/XMLLightweightParser.java in Ignite Realtime Openfire before 3.9.2 does not properly restrict the processing of compressed XML elements, which allows remote attackers to cause a denial of service (resource consumption) via a crafted XMPP stream, aka an \"xmppbomb\" attack.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ignite Realtime Openfire vulnerable to XMPPbomb attack","id":"CVE-2014-2741","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2014"},"n_packages":2,"n_references":6,"next":{"headline":"Denial of service in n/a","id":"CVE-2014-2742"},"packages":[{"ecosystem":"Maven","fixed":["3.9.2"],"introduced":["0"],"last_affected":[],"package":"org.igniterealtime.openfire:parent","purl":null,"source":"GHSA-j5qh-cp3p-2h87"},{"ecosystem":"Maven","fixed":["3.9.2"],"introduced":["0"],"last_affected":[],"package":"org.igniterealtime.openfire:parent","purl":"pkg:maven/org.igniterealtime.openfire/parent","source":"GHSA-j5qh-cp3p-2h87"}],"prev":{"headline":"Null dereference in n/a","id":"CVE-2014-2739"},"products":["n/a"],"published":"2014-04-11","related":[{"cvss_score":8.6,"headline":"Ignite Realtime Openfire Path Traversal","id":"CVE-2023-32315","kev_date_added":"2023-08-24","published":"2023-05-26"},{"cvss_score":9.8,"headline":"Ignite Realtime Openfire privilege escalation vulnerability","id":"CVE-2024-25421","kev_date_added":null,"published":"2024-03-26"},{"cvss_score":9.8,"headline":"Path traversal in n/a","id":"CVE-2021-45967","kev_date_added":null,"published":"2022-03-18"},{"cvss_score":9.8,"headline":"Ignite Realtime Openfire vulnerable to Server Side Request Forgery","id":"CVE-2019-18394","kev_date_added":null,"published":"2019-10-24"},{"cvss_score":7.5,"headline":"Security feature bypass in n/a","id":"CVE-2014-3451","kev_date_added":null,"published":"2017-08-18"},{"cvss_score":7.5,"headline":"Path traversal in n/a","id":"CVE-2008-6508","kev_date_added":null,"published":"2009-03-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service in Openfire XMPP server via crafted compressed XML streams, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2014-2741/"}