# CVE-2014-2828: OpenStack Identity (Keystone) DoS through V3 API authentication chaining

> Remote attackers can cause denial of service via CPU consumption in OpenStack Keystone by sending requests with repeated authentication methods.

- **Severity:** High 7.8 (`AV:N/AC:L/Au:N/C:N/I:N/A:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2014
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2014-2828, GHSA-6mv3-p2gr-wgqf, PYSEC-2014-106

## What is CVE-2014-2828?

CVE-2014-2828 is a high-severity denial of service vulnerability in n/a, published on 15 Apr 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The V3 API in OpenStack Identity (Keystone) 2013.1 before 2013.2.4 and icehouse before icehouse-rc2 allows remote attackers to cause a denial of service (CPU consumption) via a large number of the same authentication method in a request, aka "authentication chaining."

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2014-2828?

3 open source packages ship an affected version, including keystone. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keystone` | PyPI | All versions | 8.0.0a0 |
| `keystone` | PyPI | All versions | 8.0.0a0 |
| `keystone` | PyPI | All versions | 8.0.0a0 |

Products: Openstack Keystone.

## How do I fix CVE-2014-2828?

Upgrade keystone to 8.0.0a0 or later.

## Is CVE-2014-2828 being exploited?

There is no known exploitation of CVE-2014-2828 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-12690](https://insights.sbomify.com/CVE-2020-12690/): Insufficient Session Expiration in OpenStack Keystone (high 8.8)
- [CVE-2019-19687](https://insights.sbomify.com/CVE-2019-19687/): OpenStack Keystone Credential Leakage (high 8.8)
- [CVE-2026-43001](https://insights.sbomify.com/CVE-2026-43001/): OpenStack Keystone has an Incorrect Authorization Issue (high 7.9)
- [CVE-2021-38155](https://insights.sbomify.com/CVE-2021-38155/): OpenStack Keystone allows information disclosure during account locking (high 7.5)
- [CVE-2015-7546](https://insights.sbomify.com/CVE-2015-7546/): OpenStack Identity Keystone and keystonemiddleware Insufficiently Protected Credentials (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-2828 and fix it if it is affected.

What it is: CVE-2014-2828 is a high-severity denial of service vulnerability in n/a, published on 15 Apr 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-2828 in the wild and no public exploit code.

Affected packages and fixed versions:
- keystone (PyPI): affected all versions; fixed in 8.0.0a0
- keystone (PyPI): affected all versions; fixed in 8.0.0a0
- keystone (PyPI): affected all versions; fixed in 8.0.0a0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-2828/ (Markdown: https://insights.sbomify.com/CVE-2014-2828/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-2828
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-2828
- OSV: https://osv.dev/vulnerability/CVE-2014-2828

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-2828/
Summaries are generated and may contain mistakes; the official description above is the record.
