{"answers":{"affected":"2 open source packages ship an affected version, including MongooseIM. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-2829 in the wild and no public exploit code.","fix":"Upgrade MongooseIM to 1.3.2 or later.","what":"CVE-2014-2829 is a high-severity denial of service vulnerability in n/a, published on 11 Apr 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-2829 and fix it if it is affected.\n\nWhat it is: CVE-2014-2829 is a high-severity denial of service vulnerability in n/a, published on 11 Apr 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-2829 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- MongooseIM (Hex): affected all versions; fixed in 1.3.2\n- MongooseIM (Hex): affected all versions; fixed in 1.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-2829/ (Markdown: https://insights.sbomify.com/CVE-2014-2829/index.md)","id":"CVE-2014-2829","markdown":"https://insights.sbomify.com/CVE-2014-2829/index.md","name":"CVE-2014-2829","record":{"aliases":["GHSA-5v5w-44w6-q5hv"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"XMPP server","requires_auth":"none","summary":"Remote attackers can cause denial of service in MongooseIM via crafted XMPP streams exploiting compressed XML processing.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"mongooseim","vendor":"erlang-solutions"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:N/A:C","version":"2.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"Erlang Solutions MongooseIM through 1.3.1 rev. 2 does not properly restrict the processing of compressed XML elements, which allows remote attackers to cause a denial of service (resource consumption) via a crafted XMPP stream, aka an \"xmppbomb\" attack.","ecosystems":["Hex"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Erlang Solutions MongooseIM vulnerable to denial of service (DoS) via crafted XMPP stream","id":"CVE-2014-2829","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Hex","product":null,"products":[],"type":"denial_of_service","year":"2014"},"n_packages":2,"n_references":2,"next":{"headline":"Memory corruption in n/a","id":"CVE-2014-2830"},"packages":[{"ecosystem":"Hex","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"MongooseIM","purl":null,"source":"GHSA-5v5w-44w6-q5hv"},{"ecosystem":"Hex","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"MongooseIM","purl":"pkg:hex/MongooseIM","source":"GHSA-5v5w-44w6-q5hv"}],"prev":{"headline":"OpenStack Identity (Keystone) DoS through V3 API authentication chaining","id":"CVE-2014-2828"},"products":["n/a"],"published":"2014-04-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service in MongooseIM via crafted XMPP streams exploiting compressed XML processing.","url":"https://insights.sbomify.com/CVE-2014-2829/"}