CVE-2014-2853 Cross-site scripting vulnerability in includes/actions/InfoAction.php
Remote attackers can inject arbitrary web script or HTML via the sort key in an info action, potentially compromising user sessions or data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2014-2853?
CVE-2014-2853 is a medium-severity cross-site scripting vulnerability in Mediawiki Mediawiki, published on 29 Apr 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in includes/actions/InfoAction.php in MediaWiki before 1.21.9 and 1.22.x before 1.22.6 allows remote attackers to inject arbitrary web script or HTML via the sort key in an info action.
Weakness: CWE-79
Which versions are affected by CVE-2014-2853?
4 open source packages ship an affected version, including mediawiki/core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki/core Packagist | All versions | 1.21.9 |
mediawiki/core Packagist | All versions | 1.21.9 |
mediawiki/core Packagist | From 1.22.0 | 1.22.6 |
mediawiki/core Packagist | From 1.22.0 | 1.22.6 |
Products include Mediawiki Mediawiki.
How do I fix CVE-2014-2853?
Upgrade mediawiki/core to a fixed version for your release line: 1.21.9 or 1.22.6.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2014-2853 being exploited?
There is no known exploitation of CVE-2014-2853 in the wild and no public exploit code.
Other vulnerabilities in Mediawiki Mediawiki
Sources
Also known as GHSA-6h86-9r5g-f2h5, MGASA-2014-0197.