# CVE-2014-2853: Cross-site scripting vulnerability in includes/actions/InfoAction.php

> Remote attackers can inject arbitrary web script or HTML via the sort key in an info action, potentially compromising user sessions or data.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Apr 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-6h86-9r5g-f2h5, MGASA-2014-0197

## What is CVE-2014-2853?

CVE-2014-2853 is a medium-severity cross-site scripting vulnerability in Mediawiki Mediawiki, published on 29 Apr 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in includes/actions/InfoAction.php in MediaWiki before 1.21.9 and 1.22.x before 1.22.6 allows remote attackers to inject arbitrary web script or HTML via the sort key in an info action.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2014-2853?

4 open source packages ship an affected version, including mediawiki/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki/core` | Packagist | All versions | 1.21.9 |
| `mediawiki/core` | Packagist | All versions | 1.21.9 |
| `mediawiki/core` | Packagist | From 1.22.0 | 1.22.6 |
| `mediawiki/core` | Packagist | From 1.22.0 | 1.22.6 |

Products: Mediawiki Mediawiki.

## How do I fix CVE-2014-2853?

Upgrade mediawiki/core to a fixed version for your release line: 1.21.9 or 1.22.6.

## Is CVE-2014-2853 being exploited?

There is no known exploitation of CVE-2014-2853 in the wild and no public exploit code.

## Other vulnerabilities in Mediawiki Mediawiki

- [CVE-2023-37303](https://insights.sbomify.com/CVE-2023-37303/): Denial of service in n/a (critical 9.8)
- [CVE-2022-29904](https://insights.sbomify.com/CVE-2022-29904/): SQL injection in n/a (critical 9.8)
- [CVE-2022-29906](https://insights.sbomify.com/CVE-2022-29906/): Missing authorization in n/a (critical 9.8)
- [CVE-2022-28205](https://insights.sbomify.com/CVE-2022-28205/): Business logic in n/a (critical 9.8)
- [CVE-2022-28206](https://insights.sbomify.com/CVE-2022-28206/): Missing authorization in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-2853 and fix it if it is affected.

What it is: CVE-2014-2853 is a medium-severity cross-site scripting vulnerability in Mediawiki Mediawiki, published on 29 Apr 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2014-2853 in the wild and no public exploit code.

Affected packages and fixed versions:
- mediawiki/core (Packagist): affected all versions; fixed in 1.21.9
- mediawiki/core (Packagist): affected all versions; fixed in 1.21.9
- mediawiki/core (Packagist): affected from 1.22.0; fixed in 1.22.6
- mediawiki/core (Packagist): affected from 1.22.0; fixed in 1.22.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-2853/ (Markdown: https://insights.sbomify.com/CVE-2014-2853/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-2853
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-2853
- OSV: https://osv.dev/vulnerability/CVE-2014-2853

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-2853/
Summaries are generated and may contain mistakes; the official description above is the record.
