{"answers":{"affected":"2 open source packages ship an affected version, including sfpagent. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-2888 in the wild and no public exploit code.","fix":"Upgrade sfpagent to 0.4.15 or later.","what":"CVE-2014-2888 is a high-severity command injection vulnerability in n/a, published on 23 Apr 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-2888 and fix it if it is affected.\n\nWhat it is: CVE-2014-2888 is a high-severity command injection vulnerability in n/a, published on 23 Apr 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-2888 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sfpagent (RubyGems): affected all versions; fixed in 0.4.15\n- sfpagent (RubyGems): affected all versions; fixed in 0.4.15\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-2888/ (Markdown: https://insights.sbomify.com/CVE-2014-2888/index.md)","id":"CVE-2014-2888","markdown":"https://insights.sbomify.com/CVE-2014-2888/index.md","name":"CVE-2014-2888","record":{"aliases":["GHSA-vm28-mrm7-fpjq"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby sfpagent gem","requires_auth":"none","summary":"Remote attackers can execute arbitrary commands via shell metacharacters in the module name of a JSON request to the sfpagent Ruby gem.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"sfpagent","vendor":"herry"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[],"description":"lib/sfpagent/bsig.rb in the sfpagent gem before 0.4.15 for Ruby allows remote attackers to execute arbitrary commands via shell metacharacters in the module name in a JSON request.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"sfpagent Command Injection vulnerability","id":"CVE-2014-2888","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"command_injection","year":"2014"},"n_packages":2,"n_references":4,"next":{"headline":"Integer overflow in n/a","id":"CVE-2014-2889"},"packages":[{"ecosystem":"RubyGems","fixed":["0.4.15"],"introduced":["0"],"last_affected":[],"package":"sfpagent","purl":null,"source":"GHSA-vm28-mrm7-fpjq"},{"ecosystem":"RubyGems","fixed":["0.4.15"],"introduced":["0"],"last_affected":[],"package":"sfpagent","purl":"pkg:gem/sfpagent","source":"GHSA-vm28-mrm7-fpjq"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2014-2887"},"products":["n/a"],"published":"2014-04-23","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary commands via shell metacharacters in the module name of a JSON request to the sfpagent Ruby gem.","url":"https://insights.sbomify.com/CVE-2014-2888/"}