{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2014-2913 in the wild and no public exploit code.","fix":"Change a configuration setting.","what":"CVE-2014-2913 is a high-severity command injection vulnerability in Opensuse Opensuse, published on 7 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-2913 and fix it if it is affected.\n\nWhat it is: CVE-2014-2913 is a high-severity command injection vulnerability in Opensuse Opensuse, published on 7 May 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-2913 in the wild and no public exploit code.\n\nAffected product: Opensuse Opensuse. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-2913/ (Markdown: https://insights.sbomify.com/CVE-2014-2913/index.md)","id":"CVE-2014-2913","markdown":"https://insights.sbomify.com/CVE-2014-2913/index.md","name":"CVE-2014-2913","record":{"aliases":["DEBIAN-CVE-2014-2913","GHSA-95rp-rj38-x3rc","MGASA-2014-0217","SUSE-SU-2024:1417-1","openSUSE-SU-2024:11099-1"],"analysis":{"component_type":"server_software","fix_type":"configuration_change","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Nagios NRPE","requires_auth":"none","summary":"Remote attackers can execute arbitrary commands via newline injection in NRPE if the dont_blame_nrpe option is enabled.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"remote_plugin_executor","vendor":"nagios"},{"product":"opensuse","vendor":"opensuse"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[],"description":"Incomplete blacklist vulnerability in nrpe.c in Nagios Remote Plugin Executor (NRPE) 2.15 and earlier allows remote attackers to execute arbitrary commands via a newline character in the -a option to libexec/check_nrpe.  NOTE: this issue is disputed by multiple parties. It has been reported that the vendor allows newlines as \"expected behavior.\" Also, this issue can only occur when the administrator enables the \"dont_blame_nrpe\" option in nrpe.conf despite the \"HIGH security risk\" warning within the comments","ecosystems":["SUSE:Linux Enterprise Server 12 SP5","SUSE:Linux Enterprise Server for SAP Applications 12 SP5","openSUSE:Tumbleweed"],"exploits":{"exploitdb":2,"first_seen":"2014-04-18","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2014-04-18","kind":"exploitdb","ref":"32925","stars":null,"title":"NRPE 2.15 - Remote Command Execution"},{"date":"2014-08-29","kind":"exploitdb","ref":"34461","stars":null,"title":"NRPE 2.15 - Remote Code Execution"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Command injection in n/a","id":"CVE-2014-2913","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"opensuse:opensuse","products":["opensuse:opensuse"],"type":"command_injection","year":"2014"},"n_packages":3,"n_references":9,"next":{"headline":"Code injection in n/a","id":"CVE-2014-2914"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Server 12 SP5","fixed":["2.15-6.6.1"],"introduced":["0"],"last_affected":[],"package":"nrpe","purl":"pkg:rpm/suse/nrpe\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP5","source":"SUSE-SU-2024:1417-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP5","fixed":["2.15-6.6.1"],"introduced":["0"],"last_affected":[],"package":"nrpe","purl":"pkg:rpm/suse/nrpe\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP5","source":"SUSE-SU-2024:1417-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["4.0.3-3.5"],"introduced":["0"],"last_affected":[],"package":"nrpe","purl":"pkg:rpm/opensuse/nrpe\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11099-1"}],"prev":{"headline":"Other in n/a","id":"CVE-2014-2909"},"products":["n/a"],"published":"2014-05-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary commands via newline injection in NRPE if the dont_blame_nrpe option is enabled.","url":"https://insights.sbomify.com/CVE-2014-2913/"}