# CVE-2014-2921: Pimcore Vulnerable to PHP Object Injection Attacks

> Remote attackers can execute arbitrary code in Pimcore CMS via PHP object injection in the Newsletter module.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Apr 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-g7pj-3v97-3vxp

## What is CVE-2014-2921?

CVE-2014-2921 is a high-severity unsafe deserialization vulnerability in Pimcore Pimcore, published on 21 Apr 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The getObjectByToken function in Newsletter.php in the Pimcore_Tool_Newsletter module in pimcore 1.4.9 through 2.0.0 does not properly handle an object obtained by unserializing Lucene search data, which allows remote attackers to conduct PHP object injection attacks and execute arbitrary code via vectors involving a Zend_Pdf_ElementFactory_Proxy object and a pathname with a trailing \0 character.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2014-2921?

2 open source packages ship an affected version, including pimcore/pimcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/pimcore` | Packagist | From 1.4.9 | 2.2.0 |
| `pimcore/pimcore` | Packagist | From 1.4.9 | 2.2.0 |

Products: Pimcore Pimcore.

## How do I fix CVE-2014-2921?

Upgrade pimcore/pimcore to 2.2.0 or later.

## Is CVE-2014-2921 being exploited?

There is no known exploitation of CVE-2014-2921 in the wild and no public exploit code.

Public exploit code:

- Pimcore CMS 1.4.9 <2.1.0 - Multiple Vulnerabilities (exploitdb)

## Other vulnerabilities in Pimcore Pimcore

- [CVE-2022-39365](https://insights.sbomify.com/CVE-2022-39365/): RCE vulnerability in Pimcore/Mail & Dynamic Text Layout (critical 9.8)
- [CVE-2019-18981](https://insights.sbomify.com/CVE-2019-18981/): Pimcore Access Control Issues (critical 9.8)
- [CVE-2019-18985](https://insights.sbomify.com/CVE-2019-18985/): Pimcore 2FA Vulnerable to Brute Forcing (critical 9.8)
- [CVE-2026-23492](https://insights.sbomify.com/CVE-2026-23492/): Pimcore has a Blind SQL Injection in Admin Search Find API due to an incomplete fix for CVE-2023-30848 (high 8.8)
- [CVE-2023-47637](https://insights.sbomify.com/CVE-2023-47637/): SQL Injection in Admin Grid Filter API in Pimcore (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-2921 and fix it if it is affected.

What it is: CVE-2014-2921 is a high-severity unsafe deserialization vulnerability in Pimcore Pimcore, published on 21 Apr 2014. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-2921 in the wild and no public exploit code.

Affected packages and fixed versions:
- pimcore/pimcore (Packagist): affected from 1.4.9; fixed in 2.2.0
- pimcore/pimcore (Packagist): affected from 1.4.9; fixed in 2.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-2921/ (Markdown: https://insights.sbomify.com/CVE-2014-2921/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-2921
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-2921
- OSV: https://osv.dev/vulnerability/CVE-2014-2921

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-2921/
Summaries are generated and may contain mistakes; the official description above is the record.
