# CVE-2014-3007: Pillow command injection

> Remote attackers can execute arbitrary commands via shell metacharacters in image files processed by the Python Image Library.

- **Severity:** Critical 10.0 (`AV:N/AC:L/Au:N/C:C/I:C/A:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Apr 2014
- **Updated:** 17 Sep 2024
- **Also known as:** DEBIAN-CVE-2014-3007, GHSA-8m9x-pxwq-j236, MGASA-2014-0476, PYSEC-2014-87, UBUNTU-CVE-2014-3007

## What is CVE-2014-3007?

CVE-2014-3007 is a critical command injection vulnerability in Python Pillow, published on 27 Apr 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Python Image Library (PIL) 1.1.7 and earlier and Pillow 2.3 might allow remote attackers to execute arbitrary commands via shell metacharacters in unspecified vectors related to CVE-2014-1932, possibly JpegImagePlugin.py.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2014-3007?

3 open source packages ship an affected version, including pillow. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pillow` | PyPI | All versions | 2.5.0 |
| `pillow` | PyPI | All versions | 2.5.0 |
| `pillow` | PyPI | All versions | 2.5.0 |

Products: Python Pillow, Pythonware Python Imaging Library.

## How do I fix CVE-2014-3007?

Upgrade pillow to 2.5.0 or later.

## Is CVE-2014-3007 being exploited?

There is no known exploitation of CVE-2014-3007 in the wild and no public exploit code.

## Other vulnerabilities in Python Pillow

- [CVE-2026-96639](https://insights.sbomify.com/CVE-2026-96639/): Pillow multi-frame loaders can reuse stale native image storage after mode transitions (critical 9.8)
- [CVE-2022-30595](https://insights.sbomify.com/CVE-2022-30595/): Buffer over-flow in Pillow (critical 9.8)
- [CVE-2021-25289](https://insights.sbomify.com/CVE-2021-25289/): Out of bounds write in Pillow (critical 9.8)
- [CVE-2016-4009](https://insights.sbomify.com/CVE-2016-4009/): Pillow Integer overflow in ImagingResampleHorizontal (critical 9.8)
- [CVE-2026-112393](https://insights.sbomify.com/CVE-2026-112393/): Pillow: Heap buffer overflow in _tiffWriteProc when saving TIFF to BytesIO (critical 9.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3007 and fix it if it is affected.

What it is: CVE-2014-3007 is a critical command injection vulnerability in Python Pillow, published on 27 Apr 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2014-3007 in the wild and no public exploit code.

Affected packages and fixed versions:
- pillow (PyPI): affected all versions; fixed in 2.5.0
- pillow (PyPI): affected all versions; fixed in 2.5.0
- pillow (PyPI): affected all versions; fixed in 2.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3007/ (Markdown: https://insights.sbomify.com/CVE-2014-3007/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3007
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3007
- OSV: https://osv.dev/vulnerability/CVE-2014-3007

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3007/
Summaries are generated and may contain mistakes; the official description above is the record.
