# CVE-2014-3120: Elasticsearch Remote Code Execution

> Remote attackers can execute arbitrary Java code via the search source parameter due to enabled dynamic scripting in default configurations.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Yes, since 25 Mar 2022 (CISA KEV)
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jul 2014
- **Updated:** 22 Oct 2025
- **Also known as:** GHSA-mrfm-jxgf-2h6v

## What is CVE-2014-3120?

CVE-2014-3120 is a high-severity code injection vulnerability in Elastic Elasticsearch, published on 28 Jul 2014. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The default configuration in Elasticsearch before 1.2 enables dynamic scripting, which allows remote attackers to execute arbitrary MVEL expressions and Java code via the source parameter to _search.  NOTE: this only violates the vendor's intended security policy if the user does not run Elasticsearch in its own independent virtual machine.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2014-3120?

2 open source packages ship an affected version, including org.elasticsearch:elasticsearch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.elasticsearch:elasticsearch` | Maven | All versions | 1.4.0.Beta1 |
| `org.elasticsearch:elasticsearch` | Maven | All versions | 1.4.0.Beta1 |

Products: Elastic Elasticsearch.

## How do I fix CVE-2014-3120?

Upgrade org.elasticsearch:elasticsearch to 1.4.0.Beta1 or later. US federal agencies must fix it by 15 Apr 2022.

## Is CVE-2014-3120 being exploited?

Yes. Attackers have exploited CVE-2014-3120 in the wild since at least 25 Mar 2022.

Public exploit code:

- POC Code to exploite CVE-2014-3120 (github_poc): https://github.com/echohtp/ElasticSearch-CVE-2014-3120
- ElasticSearch Dynamic Script Arbitrary Java Execution (metasploit)
- Demonstration of CVE-2014-3120 (github_poc): https://github.com/jeffgeiger/es_inject
- ElasticSearch - Remote Code Execution (exploitdb)
- ElasticSearch Dynamic Script - Arbitrary Java Execution (Metasploit) (exploitdb)
- https://github.com/xpgdgit/CVE-2014-3120 (github_poc): https://github.com/xpgdgit/CVE-2014-3120

## Other vulnerabilities in Elastic Elasticsearch

- [CVE-2015-1427](https://insights.sbomify.com/CVE-2015-1427/): Elasticsearch Groovy Scripting Engine Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5377](https://insights.sbomify.com/CVE-2015-5377/): Code injection in n/a (critical 9.8)
- [CVE-2026-72649](https://insights.sbomify.com/CVE-2026-72649/): Deserialization of Untrusted Data in Elasticsearch Leading to Remote Code Execution (high 8.8)
- [CVE-2026-72642](https://insights.sbomify.com/CVE-2026-72642/): Use of Out-of-range Pointer Offset in the Elasticsearch Machine Learning Native Inference Process (high 8.8)
- [CVE-2020-7014](https://insights.sbomify.com/CVE-2020-7014/): Privilege Escalation Flaw in Elasticsearch (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3120 and fix it if it is affected.

What it is: CVE-2014-3120 is a high-severity code injection vulnerability in Elastic Elasticsearch, published on 28 Jul 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2014-3120 in the wild since at least 25 Mar 2022.

Affected packages and fixed versions:
- org.elasticsearch:elasticsearch (Maven): affected all versions; fixed in 1.4.0.Beta1
- org.elasticsearch:elasticsearch (Maven): affected all versions; fixed in 1.4.0.Beta1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3120/ (Markdown: https://insights.sbomify.com/CVE-2014-3120/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3120
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3120
- OSV: https://osv.dev/vulnerability/CVE-2014-3120

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3120/
Summaries are generated and may contain mistakes; the official description above is the record.
