# CVE-2014-3146: lxml Cross-site Scripting Via Control Characters

> Remote attackers can execute arbitrary scripts via control characters in link schemes due to incomplete blacklist filtering in the lxml.html.clean module.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 May 2014
- **Updated:** 17 Dec 2025
- **Also known as:** DEBIAN-CVE-2014-3146, DLA-0009-1, DSA-2941-1, GHSA-57qw-cc2g-pv5p, MGASA-2014-0218, PYSEC-2014-9, UBUNTU-CVE-2014-3146, USN-2217-1

## What is CVE-2014-3146?

CVE-2014-3146 is a medium-severity cross-site scripting vulnerability in n/a, published on 14 May 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Incomplete blacklist vulnerability in the lxml.html.clean module in lxml before 3.3.5 allows remote attackers to conduct cross-site scripting (XSS) attacks via control characters in the link scheme to the clean_html function.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2014-3146?

3 open source packages ship an affected version, including lxml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lxml` | PyPI | All versions | 3.3.5 |
| `lxml` | PyPI | All versions | 3.3.5 |
| `lxml` | PyPI | All versions | 3.3.5 |

Products: Lxml Lxml.

## How do I fix CVE-2014-3146?

Upgrade lxml to 3.3.5 or later.

## Is CVE-2014-3146 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-3146 exists.

Public exploit code:

- lxml - 'clean_html' Security Bypass (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2026-41066](https://insights.sbomify.com/CVE-2026-41066/): lxml: Default configuration of iterparse() and ETCompatXMLParser() allows XXE to local files (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3146 and fix it if it is affected.

What it is: CVE-2014-3146 is a medium-severity cross-site scripting vulnerability in n/a, published on 14 May 2014. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2014-3146 exists.

Affected packages and fixed versions:
- lxml (PyPI): affected all versions; fixed in 3.3.5
- lxml (PyPI): affected all versions; fixed in 3.3.5
- lxml (PyPI): affected all versions; fixed in 3.3.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3146/ (Markdown: https://insights.sbomify.com/CVE-2014-3146/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3146
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3146
- OSV: https://osv.dev/vulnerability/CVE-2014-3146

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3146/
Summaries are generated and may contain mistakes; the official description above is the record.
