{"answers":{"affected":"2 open source packages ship an affected version, including publify_core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-3211 in the wild and no public exploit code.","fix":"Upgrade publify_core to 8.0.1 or later.","what":"CVE-2014-3211 is a high-severity denial of service vulnerability in n/a, published on 9 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-3211 and fix it if it is affected.\n\nWhat it is: CVE-2014-3211 is a high-severity denial of service vulnerability in n/a, published on 9 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-3211 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- publify_core (RubyGems): affected all versions; fixed in 8.0.1\n- publify_core (RubyGems): affected all versions; fixed in 8.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-3211/ (Markdown: https://insights.sbomify.com/CVE-2014-3211/index.md)","id":"CVE-2014-3211","markdown":"https://insights.sbomify.com/CVE-2014-3211/index.md","name":"CVE-2014-3211","record":{"aliases":["GHSA-vq74-9583-hrm4"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby blogging platform","requires_auth":"none","summary":"Attackers can cause a Denial of Service in Publify, a Ruby-based blogging platform, by exploiting a resource exhaustion flaw.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"publify","vendor":"publify"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Publify before 8.0.1 is vulnerable to a Denial of Service attack","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Publify vulnerable to DoS attack","id":"CVE-2014-3211","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"denial_of_service","year":"2014"},"n_packages":2,"n_references":1,"next":{"headline":"Denial of service in n/a","id":"CVE-2014-3214"},"packages":[{"ecosystem":"RubyGems","fixed":["8.0.1"],"introduced":["0"],"last_affected":[],"package":"publify_core","purl":null,"source":"GHSA-vq74-9583-hrm4"},{"ecosystem":"RubyGems","fixed":["8.0.1"],"introduced":["0"],"last_affected":[],"package":"publify_core","purl":"pkg:gem/publify_core","source":"GHSA-vq74-9583-hrm4"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2014-3210"},"products":["n/a"],"published":"2020-01-09","related":[{"cvss_score":1.8,"headline":"Publify Vulnerable To Cross-Site Scripting (XSS) Via Redirects Requiring User Interaction","id":"CVE-2024-39311","kev_date_added":null,"published":"2025-03-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Attackers can cause a Denial of Service in Publify, a Ruby-based blogging platform, by exploiting a resource exhaustion flaw.","url":"https://insights.sbomify.com/CVE-2014-3211/"}