# CVE-2014-3211: Publify vulnerable to DoS attack

> Attackers can cause a Denial of Service in Publify, a Ruby-based blogging platform, by exploiting a resource exhaustion flaw.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Jan 2020
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-vq74-9583-hrm4

## What is CVE-2014-3211?

CVE-2014-3211 is a high-severity denial of service vulnerability in n/a, published on 9 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Publify before 8.0.1 is vulnerable to a Denial of Service attack

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2014-3211?

2 open source packages ship an affected version, including publify_core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `publify_core` | RubyGems | All versions | 8.0.1 |
| `publify_core` | RubyGems | All versions | 8.0.1 |

Products: Publify Publify.

## How do I fix CVE-2014-3211?

Upgrade publify_core to 8.0.1 or later.

## Is CVE-2014-3211 being exploited?

There is no known exploitation of CVE-2014-3211 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-39311](https://insights.sbomify.com/CVE-2024-39311/): Publify Vulnerable To Cross-Site Scripting (XSS) Via Redirects Requiring User Interaction (low 1.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3211 and fix it if it is affected.

What it is: CVE-2014-3211 is a high-severity denial of service vulnerability in n/a, published on 9 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-3211 in the wild and no public exploit code.

Affected packages and fixed versions:
- publify_core (RubyGems): affected all versions; fixed in 8.0.1
- publify_core (RubyGems): affected all versions; fixed in 8.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3211/ (Markdown: https://insights.sbomify.com/CVE-2014-3211/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3211
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3211
- OSV: https://osv.dev/vulnerability/CVE-2014-3211

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3211/
Summaries are generated and may contain mistakes; the official description above is the record.
