CVE-2014-3225 Cobbler Path Traversal vulnerability
Authenticated attackers can read arbitrary files on Cobbler servers via path traversal in the Kickstart field.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2014-3225?
CVE-2014-3225 is a medium-severity path traversal vulnerability in n/a, published on 14 May 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Absolute path traversal vulnerability in the web interface in Cobbler 2.4.x through 2.6.x allows remote authenticated users to read arbitrary files via the Kickstart field in a profile.
Weakness: CWE-22
Which versions are affected by CVE-2014-3225?
5 open source packages ship an affected version, including cobbler. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
cobbler PyPI | From 2.4.0 | 2.4.7, 2.6.4 |
cobbler PyPI | From 2.4.0 | 2.4.7 |
cobbler PyPI | From 2.4.0 | 2.4.7 |
cobbler PyPI | From 2.6.0 | 2.6.4 |
cobbler PyPI | From 2.6.0 | 2.6.4 |
Products include Cobblerd Cobbler.
How do I fix CVE-2014-3225?
Upgrade cobbler to a fixed version for your release line: 2.4.7 or 2.6.4.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2014-3225 being exploited?
There is no known exploitation of CVE-2014-3225 in the wild and no public exploit code.
Public exploit code: 1 Exploit-DB entry.
Other vulnerabilities in n/a
Sources
Also known as GHSA-xc7w-jvhx-p6q9, PYSEC-2026-797, UBUNTU-CVE-2014-3225.