{"answers":{"affected":"5 open source packages ship an affected version, including cobbler. It affects 1 product.","exploited":"There is no known exploitation of CVE-2014-3225 in the wild and no public exploit code.","fix":"Upgrade cobbler to a fixed version for your release line: 2.4.7 or 2.6.4.","what":"CVE-2014-3225 is a medium-severity path traversal vulnerability in n/a, published on 14 May 2014. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2014-3225 and fix it if it is affected.\n\nWhat it is: CVE-2014-3225 is a medium-severity path traversal vulnerability in n/a, published on 14 May 2014. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2014-3225 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cobbler (PyPI): affected from 2.4.0; fixed in 2.4.7, 2.6.4\n- cobbler (PyPI): affected from 2.4.0; fixed in 2.4.7\n- cobbler (PyPI): affected from 2.4.0; fixed in 2.4.7\n- cobbler (PyPI): affected from 2.6.0; fixed in 2.6.4\n- cobbler (PyPI): affected from 2.6.0; fixed in 2.6.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2014-3225/ (Markdown: https://insights.sbomify.com/CVE-2014-3225/index.md)","id":"CVE-2014-3225","markdown":"https://insights.sbomify.com/CVE-2014-3225/index.md","name":"CVE-2014-3225","record":{"aliases":["GHSA-xc7w-jvhx-p6q9","PYSEC-2026-797","UBUNTU-CVE-2014-3225"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Cobbler provisioning server","requires_auth":"low_privilege","summary":"Authenticated attackers can read arbitrary files on Cobbler servers via path traversal in the Kickstart field.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"cobbler","vendor":"cobblerd"}],"cvss":{"score":4,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:S/C:P/I:N/A:N","version":"2.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Absolute path traversal vulnerability in the web interface in Cobbler 2.4.x through 2.6.x allows remote authenticated users to read arbitrary files via the Kickstart field in a profile.","ecosystems":["PyPI"],"exploits":{"exploitdb":1,"first_seen":"2014-05-08","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2014-05-08","kind":"exploitdb","ref":"33252","stars":null,"title":"Cobbler 2.4.x \u003c 2.6.x - Local File Inclusion"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Cobbler Path Traversal vulnerability","id":"CVE-2014-3225","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2014"},"n_packages":5,"n_references":9,"next":{"headline":"Path traversal in n/a","id":"CVE-2014-3227"},"packages":[{"ecosystem":"PyPI","fixed":["2.4.7","2.6.4"],"introduced":["2.4.0","2.6.0"],"last_affected":[],"package":"cobbler","purl":"pkg:pypi/cobbler","source":"PYSEC-2026-797"},{"ecosystem":"PyPI","fixed":["2.4.7"],"introduced":["2.4.0"],"last_affected":[],"package":"cobbler","purl":null,"source":"GHSA-xc7w-jvhx-p6q9"},{"ecosystem":"PyPI","fixed":["2.4.7"],"introduced":["2.4.0"],"last_affected":[],"package":"cobbler","purl":"pkg:pypi/cobbler","source":"GHSA-xc7w-jvhx-p6q9"},{"ecosystem":"PyPI","fixed":["2.6.4"],"introduced":["2.6.0"],"last_affected":[],"package":"cobbler","purl":null,"source":"GHSA-xc7w-jvhx-p6q9"},{"ecosystem":"PyPI","fixed":["2.6.4"],"introduced":["2.6.0"],"last_affected":[],"package":"cobbler","purl":"pkg:pypi/cobbler","source":"GHSA-xc7w-jvhx-p6q9"}],"prev":{"headline":"Denial of service in Quidway S9700,Quidway S9300,Quidway S7700,Quidway S6700,Quidway S6300,Quidway S5700,Quidway S5300 Quidway S9700 V200R003C00SPC500,Quidway S9300 V200R003C00SPC500,Quidway S7700 V200R003C00SPC500,Quidway S6700 V200R003C00SPC300,Quidway S6300 V200R003C00SPC300,Quidway S5700 V200R003C00SPC300,Quidway S5300 V200R003C00SPC300","id":"CVE-2014-3224"},"products":["n/a"],"published":"2014-05-14","related":[{"cvss_score":9.8,"headline":"Cobbler Improper Validation of Security Tokens","id":"CVE-2018-1000226","kev_date_added":null,"published":"2018-08-20"},{"cvss_score":8.8,"headline":"Cobbler Web Interface Lacks CSRF Protection","id":"CVE-2011-4952","kev_date_added":null,"published":"2019-11-19"},{"cvss_score":7.8,"headline":"Privilege escalation in cobbler","id":"CVE-2011-4954","kev_date_added":null,"published":"2019-11-19"},{"cvss_score":6.1,"headline":"Cobbler XSS Vulnerability","id":"CVE-2018-1000225","kev_date_added":null,"published":"2018-08-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Authenticated attackers can read arbitrary files on Cobbler servers via path traversal in the Kickstart field.","url":"https://insights.sbomify.com/CVE-2014-3225/"}