# CVE-2014-3225: Cobbler Path Traversal vulnerability

> Authenticated attackers can read arbitrary files on Cobbler servers via path traversal in the Kickstart field.

- **Severity:** Medium 4.0 (`AV:N/AC:L/Au:S/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2014
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-xc7w-jvhx-p6q9, PYSEC-2026-797, UBUNTU-CVE-2014-3225

## What is CVE-2014-3225?

CVE-2014-3225 is a medium-severity path traversal vulnerability in n/a, published on 14 May 2014. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Absolute path traversal vulnerability in the web interface in Cobbler 2.4.x through 2.6.x allows remote authenticated users to read arbitrary files via the Kickstart field in a profile.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2014-3225?

5 open source packages ship an affected version, including cobbler. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cobbler` | PyPI | From 2.4.0 | 2.4.7, 2.6.4 |
| `cobbler` | PyPI | From 2.4.0 | 2.4.7 |
| `cobbler` | PyPI | From 2.4.0 | 2.4.7 |
| `cobbler` | PyPI | From 2.6.0 | 2.6.4 |
| `cobbler` | PyPI | From 2.6.0 | 2.6.4 |

Products: Cobblerd Cobbler.

## How do I fix CVE-2014-3225?

Upgrade cobbler to a fixed version for your release line: 2.4.7 or 2.6.4.

## Is CVE-2014-3225 being exploited?

There is no known exploitation of CVE-2014-3225 in the wild and no public exploit code.

Public exploit code:

- Cobbler 2.4.x < 2.6.x - Local File Inclusion (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2018-1000226](https://insights.sbomify.com/CVE-2018-1000226/): Cobbler Improper Validation of Security Tokens (critical 9.8)
- [CVE-2011-4952](https://insights.sbomify.com/CVE-2011-4952/): Cobbler Web Interface Lacks CSRF Protection (high 8.8)
- [CVE-2011-4954](https://insights.sbomify.com/CVE-2011-4954/): Privilege escalation in cobbler (high 7.8)
- [CVE-2018-1000225](https://insights.sbomify.com/CVE-2018-1000225/): Cobbler XSS Vulnerability (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2014-3225 and fix it if it is affected.

What it is: CVE-2014-3225 is a medium-severity path traversal vulnerability in n/a, published on 14 May 2014. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2014-3225 in the wild and no public exploit code.

Affected packages and fixed versions:
- cobbler (PyPI): affected from 2.4.0; fixed in 2.4.7, 2.6.4
- cobbler (PyPI): affected from 2.4.0; fixed in 2.4.7
- cobbler (PyPI): affected from 2.4.0; fixed in 2.4.7
- cobbler (PyPI): affected from 2.6.0; fixed in 2.6.4
- cobbler (PyPI): affected from 2.6.0; fixed in 2.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2014-3225/ (Markdown: https://insights.sbomify.com/CVE-2014-3225/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2014-3225
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2014-3225
- OSV: https://osv.dev/vulnerability/CVE-2014-3225

---
From sbomify Insights: https://insights.sbomify.com/CVE-2014-3225/
Summaries are generated and may contain mistakes; the official description above is the record.
